php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #54025 ResourceBundle fails to read files with uppercase characters
Submitted: 2011-02-15 14:28 UTC Modified: 2011-04-18 18:34 UTC
From: bschussek at gmail dot com Assigned:
Status: Duplicate Package: I18N and L10N related
PHP Version: 5.3SVN-2011-02-15 (snap) OS: Ubuntu 10.10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bschussek at gmail dot com
New email:
PHP Version: OS:

 

 [2011-02-15 14:28 UTC] bschussek at gmail dot com
Description:
------------
A bundle named "supplementalData" can't be read by ResourceBundle. If the bundle 
is named "supplementaldata" instead, loading works.

To reproduce, create a supplementalData.txt with this content:

--- BEGIN ---
supplementalData{
}
--- END ---

Then run genrb on the CLI:

$ genrb supplementalData.txt

which will generate a supplementalData.res needed by the test. genrb will output 
a warning, but you can ignore that for the purpose of this test.

Test script:
---------------
<?php
$bundle = new \ResourceBundle('supplementalData', __DIR__);
var_dump($bundle instanceof \ResourceBundle);

Expected result:
----------------
bool(true)

Actual result:
--------------
bool(false)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-15 14:37 UTC] cataphract@php.net
-Package: Unknown/Other Function +Package: I18N and L10N related
 [2011-04-18 14:53 UTC] david dot zuelke at bitextender dot com
Duplicate of http://bugs.php.net/54540
 [2011-04-18 18:34 UTC] johannes@php.net
-Status: Open +Status: Duplicate
 [2011-04-18 18:34 UTC] johannes@php.net
As David said :-)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Oct 30 09:01:25 2020 UTC