php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #53990 Broken page links within CHM
Submitted: 2011-02-11 03:22 UTC Modified: 2014-11-18 11:30 UTC
Votes:6
Avg. Score:3.8 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: aserg45 at yahoo dot com Assigned: salathe (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Windows XP Service Pack 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aserg45 at yahoo dot com
New email:
PHP Version: OS:

 

 [2011-02-11 03:22 UTC] aserg45 at yahoo dot com
Description:
------------
There are several broken links within the English documentation CHM file (tested 
on both the January 2011 and February 2011 releases).

1. To reproduce, open the CHM (I am using the CHM viewer builtin to Windows XP).
2. Go to the Search tab, and search for "magic" (without quotes).
3. Locate and double-click (to display) the search result named "Magic Methods".
4. Click the first link of the first paragraph (labelled "__construct").
5. I receive a "Page cannot be displayed" error.

Every other link in that first paragraph gives a similar error.  There are others 
throughout the documentation that I have run across, but this is the most 
pronounced (and was the to find for this example).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-11 10:47 UTC] rquadling@php.net
-Status: Open +Status: Bogus
 [2011-02-11 10:47 UTC] rquadling@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Please read the note on http://docs.php.net/download-docs.php

"If you are using Windows XP SP2 or later and you are going to download the documentation in CHM format, you need to "unblock" the file after downloading it by right-clicking on it in Windows Explorer and selecting the "Properties" menu item, then clicking on the "Unblock" button (on Windows Vista this is within the "Security" options). Failure to unblock the documentation file may result in error messages including "Navigation to the webpage was canceled" due to Windows security restrictions."
 [2011-02-11 11:27 UTC] rquadling@php.net
-Status: Bogus +Status: Re-Opened
 [2011-02-11 11:27 UTC] rquadling@php.net
And let's just say I didn't just post that ... shall we? Thank you.



It seems all <link> and <xref> tags have lost their "." for the ".html" part ...

mk:@MSITStore:D:\php_manual_en.chm::/res/language.oop5.deconhtml#language.oop5.decon.constructor

rather than ...

mk:@MSITStore:D:\php_manual_en.chm::/res/language.oop5.decon.html#language.oop5.decon.constructor



This seems to have been fixed in a later version of the phd tools and only seems to affect the CHM file process. I've checked the online pages, the chunked HTML download and the single 
file HTML download.
 [2011-02-14 12:46 UTC] rquadling@php.net
What version of phd is used to create the downloadable CHM files?
 [2014-11-18 11:30 UTC] salathe@php.net
-Status: Re-Opened +Status: Closed -Assigned To: +Assigned To: salathe
 [2014-11-18 11:30 UTC] salathe@php.net
This seems to have been fixed at some point. The reproduce steps appear to work okay now.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 18:01:30 2024 UTC