php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53961 soap over https with custom port does work
Submitted: 2011-02-08 17:28 UTC Modified: 2011-02-14 08:24 UTC
Votes:6
Avg. Score:4.7 ± 0.5
Reproduced:6 of 6 (100.0%)
Same Version:4 (66.7%)
Same OS:1 (16.7%)
From: bender at digitalbase dot de Assigned:
Status: Open Package: OpenSSL related
PHP Version: 5.3.5 OS: WinXP 32bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
10 + 37 = ?
Subscribe to this entry?

 
 [2011-02-08 17:28 UTC] bender at digitalbase dot de
Description:
------------
SoapClient does work with https over custom port.

If one version is the OpenSSl.dll (OpenSSL 0.9.8l) from an earlier PHP take it to work. With the current, it does not work.






Test script:
---------------
// does work
$client = new SoapClient("https://localhost:21081/test_13?wsdl");



// works
$client = new SoapClient("https://localhost/test_13?wsdl");



Actual result:
--------------
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://localhost:21081/test_13?wsdl' : Start tag expected, '<' not found in C:\htdocs\wwwroot\test.php:4 Stack trace: #0 C:\htdocs\wwwroot\test.php(4): SoapClient->SoapClient('https://local...') #1 {main} thrown in C:\htdocs\wwwroot\test.php on line 4

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-08 18:30 UTC] cataphract@php.net
-Status: Open +Status: Feedback
 [2011-02-08 18:30 UTC] cataphract@php.net
I have no problems with 0.9.8o-1ubuntu4.3

I can test on Windows, but to be clear: which version does not work? Is it available through windows.php.net? Which package is it?
 [2011-02-08 19:44 UTC] bender at digitalbase dot de
-Status: Feedback +Status: Open
 [2011-02-08 19:44 UTC] bender at digitalbase dot de
the current version does work PHP 5.3.5
 [2011-02-09 00:44 UTC] cataphract@php.net
-Status: Open +Status: Bogus
 [2011-02-09 00:44 UTC] cataphract@php.net
Well, if the current version works, I'm closing this bug.
 [2011-02-09 12:57 UTC] cataphract@php.net
-Status: Bogus +Status: Open
 [2011-02-09 12:57 UTC] cataphract@php.net
Re-open as the bug reported missed a "not" in his comment.

Citing the e-mail he sent:

«
> which version does not work? 
PHP 5.3.0 works
PHP 5.3.3 does not work
PHP 5.3.4 does not work
PHP 5.3.5 does not work
> Is it available through windows.php.net?  
Yes, http://windows.php.net/downloads/releases/php-5.3.5-Win32-VC9-x86.zip
»
 [2011-02-09 13:01 UTC] pajoye@php.net
and snaps per revision are available at http://rmtools.php.net/snaps/
 [2011-02-09 13:17 UTC] cataphract@php.net
I can't reproduce:

D:\Users\Cataphract\Desktop\php-5.3.5-Win32-VC9-x86>php -d extension_dir=ext -d
extension=php_soap.dll -d extension=php_openssl.dll -r "$client = new SoapClient
('https://192.168.4.5:21083/test_13.xml'); var_dump($client);"
object(SoapClient)#1 (2) {
  ["_soap_version"]=>
  int(1)
  ["sdl"]=>
  resource(6) of type (Unknown)
}
 [2011-02-09 13:26 UTC] bender at digitalbase dot de
C:\Dokumente und Einstellungen\frostm\Eigene Dateien\Downloads>cd php-5.3.5-
Win32-VC9-x86
C:\Dokumente und Einstellungen\frostm\Eigene Dateien\Downloads\php-5.3.5-Win32-
VC9-x86>php -d extension_dir=ext -d extension=php_soap.dll -d 
extension=php_openssl.dll -r "$client = new 
SoapClient('https://test.intranet:21081/service/cm/business/Contract/CapacityCon
tract/1.3?wsdl'); var_dump($client);"

Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: 
Couldn't load from 
'https://test.intranet:21081/service/cm/business/Contract/CapacityContract/1.3?
wsdl' : Start tag expected, '<' not found
 in Command line code:1
Stack trace:
#0 Command line code(1): SoapClient->SoapClient('https://ecganwt...')
#1 {main}
  thrown in Command line code on line 1

C:\Dokumente und Einstellungen\frostm\Eigene Dateien\Downloads\php-5.3.5-Win32-
VC9-x86>cd ..
C:\Dokumente und Einstellungen\frostm\Eigene Dateien\Downloads>cd php-5.3.0-
Win32-VC9-x86




C:\Dokumente und Einstellungen\frostm\Eigene Dateien\Downloads\php-5.3.0-Win32-
VC9-x86>php -d extension_dir=ext -d extension=php_soap.dll -d 
extension=php_openssl.dll -r "$client = new 
SoapClient('https://test.intranet:21081/service/cm/business/Contract/CapacityCon
tract/1.3?wsdl'); var_dump($client);"
object(SoapClient)#1 (2) {
  ["_soap_version"]=>
  int(1)
  ["sdl"]=>
  resource(9) of type (Unknown)
}
 [2011-02-09 13:27 UTC] bender at digitalbase dot de
5.3.0 works
5.3.5 not
 [2011-02-09 13:36 UTC] bender at digitalbase dot de
r308155 from svn has the same error


C:\Dokumente und Einstellungen\frostm\Eigene Dateien\Downloads>cd php-5.3-ts-
windows-vc9-x86-r308155
C:\Dokumente und Einstellungen\frostm\Eigene Dateien\Downloads\php-5.3-ts-
windows-vc9-x86-r308155>php -d extension_dir=ext -d extension=php_soap.dll -d 
extension=php_openssl.dll -r "$client = new 
SoapClient('https://test.intranet:21081/service/cm/business/Contract/CapacityCon
tract/1.3?wsdl'); var_dump($client);"

Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: 
Couldn't load from 
'https://test.intranet:21081/service/cm/business/Contract/CapacityContract/1.3?
wsdl' : Start tag expected, '<' not found in Command line code:1
Stack trace:
#0 Command line code(1): SoapClient->SoapClient('https://ecganwt...')
#1 {main}
  thrown in Command line code on line 1
 [2011-02-09 14:23 UTC] cataphract@php.net
-Status: Open +Status: Feedback
 [2011-02-09 14:23 UTC] cataphract@php.net
If you replace the OpenSSL libs (I think they're named ssleay and libeay.dll) in the PHP 5.3.5 folder with those bundled with PHP 5.3.0, do you still get the error?
 [2011-02-09 14:24 UTC] cataphract@php.net
Try also swapping ext\php_openssl.dll and ext\php_soap.dll
 [2011-02-09 14:31 UTC] bender at digitalbase dot de
-Status: Feedback +Status: Open
 [2011-02-09 14:31 UTC] bender at digitalbase dot de
PHP 5.3.5 with php_openssl.dll from PHP 5.3.0 works
(i replace only the php_openssl.dll in the ext dir from 5.3.5)
 [2011-02-13 17:10 UTC] cataphract@php.net
-Status: Open +Status: Feedback
 [2011-02-13 17:10 UTC] cataphract@php.net
Can you test whether disabling SNI solves the issue? Set the context option ssl/SNI_enabled to false. See http://php.net/manual/en/context.ssl.php

I'm shooting in the dark, but this seems one of the few meaningful changes between PHP 5.3.0 and PHP 5.3.3.
 [2011-02-14 08:07 UTC] bender at digitalbase dot de
-Status: Feedback +Status: Open
 [2011-02-14 08:07 UTC] bender at digitalbase dot de
no changes if i enable or disable SNI_enabled.

(php -d extension_dir=ext -d SNI_enabled=0 -d extension=php_soap.dll -d 
extension=php_openssl.dll)
 [2011-02-14 08:24 UTC] bender at digitalbase dot de
I've just tested again at what version the error occurs.

5.3.0 works
5.3.1 works
5.3.2 does not work
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Nov 12 10:01:35 2019 UTC