php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5396 new vars can't be added to session, existing vars values can't be changed
Submitted: 2000-07-06 11:48 UTC Modified: 2000-07-27 23:13 UTC
From: nepolon at worlddomination dot net Assigned:
Status: Closed Package: Session related
PHP Version: 4.0.1pl2 OS: Linux 2.x
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nepolon at worlddomination dot net
New email:
PHP Version: OS:

 

 [2000-07-06 11:48 UTC] nepolon at worlddomination dot net
to recreate:
1. create a session with some arbitrary number of session variables
2. Header("Location: someotherurl.php")
Now working in someotherurl.php ...
3. session_start() to re-scope the session variables for use in this page
4. attempt to change value of one of those existing session variables
5. attempt to session_register("some_new_variable")
6. beat your head against the keyboard in frustration :)

using a stock php.ini file

configure line = ./configure --with-apxs=/usr/sbin/apxs --with-config-file-path=/usr/ --enable-trans-sid --enable-wddx
[I probably should have added the --enable-mysql portion to the config line, but MySQL is working for now...]

looked for this issue in existing bug database but did not locate anything matching.  apologies if user-error caused duplication of bug report.

it is possible that something elusive or subtle that I did or did not do contributed to this behavior.  please feel free to contact me if you cannot recreate this issue.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-06 14:23 UTC] stas at cvs dot php dot net
what are your register_globals, use_cookies and track_vars?
 [2000-07-06 21:16 UTC] nepolon at worlddomination dot net
still using stock php.ini

register_globals=On
use_cookies=On
track_vars=On
 [2000-07-07 14:44 UTC] stas at cvs dot php dot net
Very strange, it should work. What session setting are you using?
 [2000-07-27 22:06 UTC] waldschrott@php.net
please provide sample code to reproduce if it still doesn?t work
 [2000-07-27 23:13 UTC] zak@php.net
Closed at user request - cannot reproduce.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jun 03 05:03:39 2023 UTC