|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53921 Segmentation fault on using new soapclient() function
Submitted: 2011-02-04 02:06 UTC Modified: 2011-02-04 20:52 UTC
Avg. Score:4.8 ± 0.4
Reproduced:2 of 3 (66.7%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: umang dot ashu at gmail dot com Assigned:
Status: Closed Package: SOAP related
PHP Version: 5.3SVN-2011-02-04 (snap) OS: RHEL
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: umang dot ashu at gmail dot com
New email:
PHP Version: OS:


 [2011-02-04 02:06 UTC] umang dot ashu at gmail dot com
I am having trouble in using SOAP extension. I installed PHP with SOAP extension but whenever there is a soapclient function call in the code.

The page either doesn't load and shows a blank page or asks to save the .php file without even showing a blank page.

In error log file for apache this error is thrown again and again on  each page load:
[Thu Feb 03 23:02:20 2011] [notice] child pid 23912 exit signal Segmentation fault (11)

I tried backtracing it using gdb. But it came out with this which makes no sense:

[root@testapp3 bin]# gdb /usr/sbin/httpd /tmp/apache-cores/core.8638
GNU gdb Red Hat Linux (6.5-16.el5rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib64/".

Core was generated by `/www/bin/httpd -k start'.
Program terminated with signal 11, Segmentation fault.
#0  0x00002aaaab3c836c in ?? ()
(gdb) where
#0  0x00002aaaab3c836c in ?? ()
#1  0x000000000000000d in ?? ()
#2  0x0000000005517bd0 in ?? ()
#3  0x000000004d49f4e4 in ?? ()
#4  0x00002aaaab3cd7cd in ?? ()
#5  0x0000000000000000 in ?? ()

I used the same php code on other machines and it works fine. Please put some light on the problem here.
Please help.


Test script:
The code breaks here, particularly in this line, in all of the pages:

$client = new SoapClient($command,$options);

Expected result:
Run the code smoothly

Actual result:
In error log file there is a segmentation fault.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-04 10:24 UTC]
-Status: Open +Status: Feedback
 [2011-02-04 10:24 UTC]
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read for *NIX and for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

In particular, we need a backtrace with symbols, which is
likely going to require debug builds of Apache and PHP.
 [2011-02-04 20:52 UTC] umang dot ashu at gmail dot com
-Status: Feedback +Status: Closed
 [2011-02-04 20:52 UTC] umang dot ashu at gmail dot com
I got it fixed eventually.

Just to tell others if anyone else gets this problem:

I installed openssl, zlib and libxml libraries in the system.
Changed symbolic links in /usr/lib directory for libz to the new version (to do this check this page: )

And then everything worked. I didnt even had to reinstall apache or php.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 20:01:29 2024 UTC