php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #53912 Yoruba language support
Submitted: 2011-02-02 21:23 UTC Modified: 2011-02-03 04:46 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: ciprianmp at yahoo dot com Assigned:
Status: Not a bug Package: Calendar related
PHP Version: 5.2.14 OS: unix
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ciprianmp at yahoo dot com
New email:
PHP Version: OS:

 

 [2011-02-02 21:23 UTC] ciprianmp at yahoo dot com
Description:
------------
---
From manual page: http://www.php.net/function.setlocale
---


Expected result:
----------------
The date/time and calendar month and days names and formats are in english, on both win and unix.
Any plans for yoruba language (Nigeria) support?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-02 21:53 UTC] ciprianmp at yahoo dot com
-Operating System: all +Operating System: unix
 [2011-02-02 21:53 UTC] ciprianmp at yahoo dot com
It seems to work on windows though, but not on linux.
 [2011-02-02 22:01 UTC] ciprianmp at yahoo dot com
-PHP Version: 5.2.17 +PHP Version: 5.2.14
 [2011-02-02 22:01 UTC] ciprianmp at yahoo dot com
win 5.2.17 - yoruba support = Yes
unix 5.2.14 - No
 [2011-02-03 04:46 UTC] aharvey@php.net
-Status: Open +Status: Bogus
 [2011-02-03 04:46 UTC] aharvey@php.net
This already works fine so long as your OS has the appropriate
language support installed. For example, after installing the Ubuntu
language-pack-yo package, this script:

<?php
var_dump(strftime('%e %B %Y'));
setlocale(LC_ALL, 'yo_NG.utf8');
var_dump(strftime('%e %B %Y'));
?>

Outputs this:

string(16) " 3 February 2011"
string(22) " 3 Fẹ́búárì 2011"

Which matches the installed locale file (apart from the broken
combining character caused by copy/pasting from my terminal).

Closing, since this isn't a bug in PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jun 06 11:01:23 2020 UTC