php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53821 go-pear installs PEAR 1.9.0 instead of 1.9.1
Submitted: 2011-01-23 12:38 UTC Modified: 2011-02-08 12:30 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: tyra3l at gmail dot com Assigned: pajoye (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.3.5 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tyra3l at gmail dot com
New email:
PHP Version: OS:

 

 [2011-01-23 12:38 UTC] tyra3l at gmail dot com
Description:
------------
yesterday I had a discussion with my friend on twitter, and he said, that the 
pear installer is broken on windows 7.
we tracked down, that his problem is a known bug and fixed in PEAR 1.9.1, caused 
by the installation path containing spaces.
http://pear.php.net/bugs/bug.php?id=16644

so it shouldn't happen right? but it does, because the go-pear shipped with the 
latest windows binaries is old, and tries to install the 1.9.0 version.
please update that to 1.9.1

there are other pear packages that needs updated, so maybe it would be a good 
idea to bump them also:

Archive_Tar-1.3.3 vs Archive_Tar-1.3.7
Console_Getopt-1.2.3 vs Console_Getopt-1.3.0
Structures_Graph-1.0.2 vs Structures_Graph-1.0.4

on the long term, maybe it would be a good idea, to modify the installer to 
fetch the latest versions on-the-fly as part of the installation process, for 
now, maybe we could add a step for upgrading(or telling the people to upgrade) 
the packages to the go-pear.bat installation process.

Test script:
---------------
fetch the windows binary, run go-pear.bat and after the successful install, check pear version, pear list

Expected result:
----------------
should list the latest versions of the installed packages

Actual result:
--------------
now it lists the old packages

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-23 12:45 UTC] bulk at janoszen dot hu
Please note, that this bug only surfaces on 64 bit Windows versions, 32 bit versions are not affected.
 [2011-01-23 13:11 UTC] tyra3l at gmail dot com
What do you mean by not affected?
AFAIK the installed PEAR version has nothing to do with the version of the OS(be 
32 or 64 bit), so this bug affects all windows versions.
if you are talking about the referenced PEAR bug ( 
http://pear.php.net/bugs/bug.php?id=16644 ) then I think thats not true also.
the source of the problem is the incorrect escaping of the shell arguments, which 
isn't related to the windows version, the only thing that makes the bug appear is 
that you have spaces in your installation path, or not.
feel free to correct me though.
 [2011-01-23 17:09 UTC] bulk at janoszen dot hu
tyra3l at gmail dot com: by not affected I mean it will not be reproducible on a standard install 32 bit platform. Sorry, wrong wording.
 [2011-01-23 17:42 UTC] bulk at janoszen dot hu
I tried to extract the URL's the PEAR installer accesses and came up with nothing. My installation log can be found here: http://pastebin.com/4yMJQiQP
 [2011-01-23 17:53 UTC] tyra3l at gmail dot com
I don't think we need any more info than already present, it's clear that the go-
pear.phar in the latest windows builds contains the 1.9.0 pear, and other old PEAR 
libs, as I mentioned in the bugreport. 

Tyrael
 [2011-01-24 01:07 UTC] pajoye@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: pajoye
 [2011-01-24 01:07 UTC] pajoye@php.net
We take the one available at http://pear.php.net/go-pear.phar by the time of the 
1st RC for a given release.

Next release(s) will have the new ones, or the snapshots for the impatient.

In the mean time, simply replace the go-pear.phar in the pear directory before 
running go-pear and it should work well.
 [2011-01-24 14:09 UTC] tyra3l at gmail dot com
So this will be fixed in 5.3.6?
Judging from the PEAR repository, it seems, that the 1.9.1 was tagged 7 month ago.
What was the reason that the last 2 release was shipped with the 1.9.0?
Do you update this manually? Maybe this could be automated in the build/release 
process, so it won't be forgotten.

Tyrael
 [2011-01-24 14:46 UTC] pajoye@php.net
I already answered this question in my comment.

And yes it is automated. No idea why 5.3.4 did not take it, but reading the log it 
did fetch it from pear.php.net.
 [2011-02-08 12:30 UTC] pajoye@php.net
-Status: Assigned +Status: Closed
 [2011-02-08 12:30 UTC] pajoye@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Fixed on the build boxes.

You can test snaps using http://rmtools.php.net/snaps/

Thanks for the report!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 02 23:05:54 2022 UTC