php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #53808 Haiku's networking functions are in -lnetwork not -lsocket
Submitted: 2011-01-22 01:35 UTC Modified: 2021-09-11 11:58 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: scottmc2 at gmail dot com Assigned: cmb (profile)
Status: Closed Package: Compile Warning
PHP Version: 5.3.5 OS: Haiku
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: scottmc2 at gmail dot com
New email:
PHP Version: OS:

 

 [2011-01-22 01:35 UTC] scottmc2 at gmail dot com
Description:
------------
Normally to fix this issue we add a simple check for socket in network, but it seems PHP is using older versions of autotools.
Also PHP-5.3.5 is including older config.sub/config.guess files, Haiku was added to these in late Jan 2008, so updating to a version from Feb 2008 or later would fix that, at least on Haiku.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-03-15 15:44 UTC] cmb@php.net
It seems <https://github.com/php/php-src/pull/2697> would solve
this issue.
 [2021-09-10 10:15 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2021-09-10 10:15 UTC] cmb@php.net
Is this still an issue with any of the actively supported PHP
versions[1]?

[1] <https://www.php.net/supported-versions.php>
 [2021-09-11 06:26 UTC] scottmc2 at gmail dot com
-Status: Feedback +Status: Assigned
 [2021-09-11 06:26 UTC] scottmc2 at gmail dot com
Looks like this got fixed in 32c6a0bbbbeddc93d14273326ecd3604961d3f0d

https://github.com/php/php-src/commit/32c6a0bbbbeddc93d14273326ecd3604961d3f0d

Thanks.  This one can be closed as fixed.

-Scott
 [2021-09-11 11:58 UTC] cmb@php.net
-Status: Assigned +Status: Closed
 [2021-09-11 11:58 UTC] cmb@php.net
Thanks for checking this!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Sep 22 22:01:41 2021 UTC