php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #53747 CHM manual releases are failing
Submitted: 2011-01-14 16:16 UTC Modified: 2011-01-17 05:40 UTC
From: vovan-ve at yandex dot ru Assigned: kalle (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vovan-ve at yandex dot ru
New email:
PHP Version: OS:

 

 [2011-01-14 16:16 UTC] vovan-ve at yandex dot ru
Description:
------------
On-line documentation about function basename() [ http://php.net/basename ] has a note:

  Note: 
  basename() is locale aware, so for it to see the correct basename with
  multibyte character paths, the matching locale must be set using the
  setlocale() function.

But offline CHM has no such note. This is true problem. I thought before that basename() just works with byte-string. I was really surprised extracting zip with cyrillic file names on different platforms. O_o

PS: Why last-mod date on index page in CHM is "2010-06-25" still?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-15 23:01 UTC] frozenfire@php.net
-Summary: "basename() is locale aware" not present in CHM +Summary: CHM manual releases are failing -Status: Open +Status: Verified -Package: Documentation problem +Package: Systems problem
 [2011-01-15 23:01 UTC] frozenfire@php.net
I've checked, and the CHM releases are indeed failing to build. The website shows them as new releases, but the date specified in the manual itself is dated back to mid-2010.

I suspect that the build of the CHM is simply failing, causing the file to not be updated.

I've moved this to PHP.net SO because it's an issue with the automatic build system, rather than an issue with the documentation itself.
 [2011-01-15 23:16 UTC] philip@php.net
-Package: Systems problem +Package: Doc Build problem
 [2011-01-15 23:16 UTC] philip@php.net
Making this a 'doc build' problem
 [2011-01-16 01:22 UTC] philip@php.net
Error from the phd log on the Windows box: "The system cannot find the path 
specified.
"

So it appears the build is happening, and chm files are being pushed/rsynced, but 
the chm files are created from an old PhD build.
 [2011-01-16 01:23 UTC] philip@php.net
-Assigned To: +Assigned To: kalle
 [2011-01-17 04:43 UTC] gena01 at gmail dot com
This might be related to or dup of bug #53321
 [2011-01-17 05:40 UTC] kalle@php.net
-Status: Verified +Status: Closed
 [2011-01-17 05:40 UTC] kalle@php.net
Fixed on the server, new builds coming this friday will contain an updated version of the manual, including the fix for bug #53321.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Mar 05 11:01:28 2024 UTC