php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53718 "user_agent" not in HTTP requests for proxied requests, even if set in $options
Submitted: 2011-01-12 11:45 UTC Modified: -
From: scaligo at pt dot lu Assigned:
Status: Open Package: SOAP related
PHP Version: 5.3.5 OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: scaligo at pt dot lu
New email:
PHP Version: OS:

 

 [2011-01-12 11:45 UTC] scaligo at pt dot lu
Description:
------------
In a manner similar to #50489, the "user_agent" (or default PHP User-Agent string) should be included in the HTTP headers when connecting through a proxy server.

Some proxy servers refuse tunneling unless a User-Agent is provided, but the SOAP extension doesn't include one event if the "user_agent" value is provided in the option headers.

Test script:
---------------
<?php

$client = new SoapClient("/path/to/some/wsdl.xml",
  array( 
    'classmap' => $CLASSMAP,
    'trace' => false,
    'user_agent' => 'PHP',
    'proxy_host' => 'cie-vproxy.cie.etat.lu',
    'proxy_port' => 80,
  )
);

/* ... */

$client->request()


Expected result:
----------------
The script should connect to the proxy server and send the request with a "User-Agent: PHP" header.

Actual result:
--------------
The request doesn't contain a "User-Agent" header and the proxy refuses to tunnel the request.

Patches

Add a Patch

Pull Requests

Add a Pull Request

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 23 18:01:26 2019 UTC