php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53529 Unable to load PDO drivers
Submitted: 2010-12-12 19:59 UTC Modified: 2010-12-12 20:30 UTC
From: foutrelis at gmail dot com Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.3.4 OS: Arch Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: foutrelis at gmail dot com
New email:
PHP Version: OS:

 

 [2010-12-12 19:59 UTC] foutrelis at gmail dot com
Description:
------------
I upgraded to PHP 5.3.4 on Arch Linux using the distribution's official packages. The previous version (5.3.3) worked great, but with the latest one it would appear that the PDO drivers are broken.

The issue I'm experiencing only occurs on i686; x86_64 is working fine. The actual problem is that after enabling PDO, and either the MySQL or PostgreSQL PDO driver (I didn't test with others), I get an error saying:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/pdo_mysql.so' - /usr/lib/php/modules/pdo_mysql.so: undefined symbol: php_pdo_unregister_driver in Unknown on line 0

And the PDO driver does not get loaded. A `php -m' shows that only PDO is being loaded successfully.

See the build function on [1] for the way Arch configures PHP. I've also opened a bug report on Arch's bug tracker [2] and will post a link to this bug there.

Let me know if I can provide any further information that might help discover the root cause of the issue.


[1] http://repos.archlinux.org/wsvn/packages/php/trunk/PKGBUILD?rev=102873
[2] https://bugs.archlinux.org/task/22072


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-12 20:27 UTC] foutrelis at gmail dot com
-Status: Open +Status: Closed
 [2010-12-12 20:27 UTC] foutrelis at gmail dot com
This bug report turned out to be invalid.

The issue was downstream, where the extensions included in the default php.ini got sorted alphabetically in this release and pdo.so ended up being below the PDO drivers. Moving it above the drivers makes it work again.

Sorry for the noise. :)
 [2010-12-12 20:30 UTC] cataphract@php.net
-Status: Closed +Status: Bogus
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 13:01:29 2024 UTC