|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53489 Passthru and Signals Appear Not Handled
Submitted: 2010-12-06 23:08 UTC Modified: -
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: broberts at ieee dot org Assigned:
Status: Open Package: Unknown/Other Function
PHP Version: 5.3.3 OS: Centos5
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: broberts at ieee dot org
New email:
PHP Version: OS:


 [2010-12-06 23:08 UTC] broberts at ieee dot org
So I'm not really sure if this is a configuration issue or a bug, but passthru doesn't seem to be handling the signal due to ulimit as expected on Centos5.  

If I run at the bash command line, I get a nice "File too large detected via return code" show up and 2.1 MB of the 5 MB file copied. So it appears cp child process caught and handled the SIGXFSZ signal.

But when I run the PHP script, while the o/s stops cp at 2.1 MB, but ${LOCALRET} is 1 (of course I also see the "Got 0 as always" message as always returns 0). Somehow the child of isn't getting the signal properly it seems. In fact if it's a more elaborate process than a cp, it will not stop the process -- The process appears not to have gotten the signal (of course the o/s won't let it write more than 2.1 MB but it seems to be obvious to the signal).

When I'm on MacOS (running same PHP 5.3.3 with Apache 2) the signals seem to work correctly. So am I misunderstanding something here? Is there a configuration setting in PHP to make the Centos behave like the MacOS?  Or is this a Centos PHP bug?

BTW the Centos configure options are:
./configure --with-mysqli --with-zlib --with-xml --with-mysql --with-openssl --enable-sockets --enable-calendar --with-curl --with-apxs2

Test script:
echo "<pre>";
echo "<br>";
echo "Got $return_code as always";
echo "</pre>";


# set max write size to 2.1 MB and trigger SIGXFSZ
ulimit -f 2100  

cp /path/5mb_file /path/5mb_file.cp

# return code = 128+SIGXFSZ = 153 (on Centos and MacOS anyway)
if [[ ${LOCALRET} -eq 153 ]]; then
 echo "File too large detected via return code"
 echo "Got ${LOCALRET}"

exit 0

Expected result:
File too large detected via return code
Got 0 as always

Actual result:
Got 1
Got 0 as always


Add a Patch

Pull Requests

Add a Pull Request

PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 22 19:01:27 2020 UTC