php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53484 closing slash does not work
Submitted: 2010-12-06 12:48 UTC Modified: 2010-12-06 12:52 UTC
From: lampacz at gmail dot com Assigned:
Status: Duplicate Package: Safe Mode/open_basedir
PHP Version: 5.3.3 OS: Linux Debian testing
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lampacz at gmail dot com
New email:
PHP Version: OS:

 

 [2010-12-06 12:48 UTC] lampacz at gmail dot com
Description:
------------
Using

php_admin_value open_basedir /var/www/domain.tld/:/usr/share/php/

Produces in error.log:

PHP Warning:  Unknown: open_basedir restriction in effect. File(/var/www/domain.tld/home/film/xinfo.php) is not within the allowed path(s): (/var/www/domain.tld/:/usr/share/php) in Unknown on line 0
PHP Warning:  Unknown: failed to open stream: Operation not permitted in Unknown on line 0
PHP Fatal error:  Unknown: Failed opening required '/var/www/domain.tld/home/film/xinfo.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0

And no output in log

After rewrite

php_admin_value open_basedir /var/www/domain.tld:/usr/share/php # no ending slash

everything start working


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-06 12:52 UTC] pajoye@php.net
-Status: Open +Status: Duplicate
 [2010-12-06 12:52 UTC] pajoye@php.net
Duplicate of #53352 (fixed in svn and last 5.3.4RC), also Debian has to update their testing tree.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Nov 28 14:01:23 2020 UTC