php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #53445 INSTALL file sections out of date
Submitted: 2010-12-02 04:30 UTC Modified: 2017-07-24 08:40 UTC
Votes:7
Avg. Score:3.3 ± 0.7
Reproduced:3 of 4 (75.0%)
Same Version:3 (100.0%)
Same OS:2 (66.7%)
From: aharvey@php.net Assigned: kalle (profile)
Status: Closed Package: *Compile Issues
PHP Version: trunk-SVN-2010-12-02 (SVN) OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: aharvey@php.net
New email:
PHP Version: OS:

 

 [2010-12-02 04:30 UTC] aharvey@php.net
Description:
------------
Some sections of the INSTALL file still refer to installing PHP 4: the
OpenBSD installation notes, for example, refer specifically to PHP
4.3.8!

We'll either need to have developers or documenters familiar with the
relevant OSes rework those sections, or alternatively point people
towards the manual and integrate anything that's in INSTALL that isn't
covered in the manual's installation section.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-25 21:14 UTC] philip@php.net
-Status: Open +Status: Analyzed
 [2011-01-25 21:14 UTC] philip@php.net
Also, we need to investigate the PHP Manual Install section to INSTALL (and 
install.txt) conversion system because it doesn't work very well.

In other words, INSTALL and install.txt are generated from the PHP Manual itself 
then committed to php-src SVN... but this hasn't been done in about three years. 
And people have made changes to INSTALL that were not folded into the PHP Manual 
itself. So, this bug report deals with this entire issue. Thoughts?
 [2017-01-28 11:28 UTC] cmb@php.net
-Type: Bug +Type: Documentation Problem -Package: Documentation problem +Package: *Compile Issues
 [2017-07-24 08:40 UTC] kalle@php.net
-Status: Analyzed +Status: Closed -Assigned To: +Assigned To: kalle
 [2017-07-24 08:40 UTC] kalle@php.net
Fixed in master, INSTALL and win32/install.txt now points directly to the docs at php.net
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 25 14:01:25 2020 UTC