php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #53218 couldnt able to connect PHP with POSTGRESQL
Submitted: 2010-11-01 12:54 UTC Modified: 2010-11-03 21:50 UTC
From: lakshmi at nace dot co dot in Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 5.2.14 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
43 - 2 = ?
Subscribe to this entry?

 
 [2010-11-01 12:54 UTC] lakshmi at nace dot co dot in
Description:
------------
<?php
$database=pg_connect("host=localhost dbname=test user=postgres");
if(!$database)
{
    die("Could not connect -> " .pg_last_error(). pg_errormessage($database));
}
?>

Test script:
---------------
<?php
$database=pg_connect("host=localhost dbname=test user=postgres");
if(!$database)
{
    die("Could not connect -> " .pg_last_error(). pg_errormessage($database));
}
else
echo "database connected";
?>
while executing above mentioned program it is throwing aPHP Fatal error:  Call to undefined function pg_connect() in /srv/www/htdocs/pg.php on line 2


Expected result:
----------------
database connected.


Hi,

 Can anyone tell me what would be the mistake in the above mentioned
program,
when I execute this program simply it is throwing an error as : Call to
undefined function pg_connect(),I can able to connect from psql
separately
but while trying to connect it from php it is throwing error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-03 21:50 UTC] kalle@php.net
-Status: Open +Status: Bogus
 [2010-11-03 21:50 UTC] kalle@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Please use a PHP support forum or one of the mailing lists, this is not a support area, Thanks
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 18 12:01:29 2024 UTC