php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53197 Problem in getting UTF-8 character from flex as soapClient in PHP as soapServer
Submitted: 2010-10-29 09:01 UTC Modified: 2010-11-11 02:22 UTC
From: vekumar at q3tech dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.2.14 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vekumar at q3tech dot com
New email:
PHP Version: OS:

 

 [2010-10-29 09:01 UTC] vekumar at q3tech dot com
Description:
------------
Hi,

I have implemented soap using flex (as soap client) and php (as soap server).
It is working fine. The problem occur when i got french data from flex (UTF-8) in PHP (all french characters are changed).
 
For example i have entered "Aérospatiale et défense" in flex interface and after pressing submit button i got "Aérospatiale et défense" in php.

I am using Doctrine ORM and already converted its dataset to UTF-8.

In same application if i read file in PHP which contain french character and save in database, it works fine and i am able to get all french character.

SO the problem is if i am getting french characters from flex.

Please help me....... 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-11 02:22 UTC] Kalle@php.net
-Status: Open +Status: Bogus
 [2010-11-11 02:22 UTC] Kalle@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 13:03:32 2021 UTC