php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53191 var_dump a regex failes
Submitted: 2010-10-28 14:07 UTC Modified: 2010-10-28 14:32 UTC
From: michelmulder at gmail dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.3.3 OS: Windows XP SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michelmulder at gmail dot com
New email:
PHP Version: OS:

 

 [2010-10-28 14:07 UTC] michelmulder at gmail dot com
Description:
------------
When i run the code i get a wrong result. var_dump stops outputting but i don't  know why.

Test script:
---------------
<?php

var_dump('#(?<![\p{Nd}\p{L}_])(test)(?![\p{Nd}\p{L}_])#iu');

?>

Expected result:
----------------
string(47) "#(?<![\p{Nd}\p{L}_])(test)(?![\p{Nd}\p{L}_])#iu"

Actual result:
--------------
string(47) "#(?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-28 14:15 UTC] salathe@php.net
-Status: Open +Status: Bogus
 [2010-10-28 14:15 UTC] salathe@php.net
Looks like you're viewing the page as HTML. View the source, or send it out as 
plain text.  Not a bug.
 [2010-10-28 14:32 UTC] michelmulder at gmail dot com
Hi,

When i'm viewing the source, the result is still not as expected. But when i send a text/plain header i get the right result. I think it's a bug in FireFox.

Thank you for your answer and sorry for wasting your time.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 03:01:24 2020 UTC