php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53147 Date interval miscalculation
Submitted: 2010-10-24 23:15 UTC Modified: 2010-10-25 01:07 UTC
From: fpbarbi at gmail dot com Assigned:
Status: Not a bug Package: Calendar related
PHP Version: 5.2.14 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fpbarbi at gmail dot com
New email:
PHP Version: OS:

 

 [2010-10-24 23:15 UTC] fpbarbi at gmail dot com
Description:
------------
I tried many consecutive days in February 2011, but this glitch only happens on that specific saturday-sunday interval.

Test script:
---------------
(strtotime("2011-02-20") - strtotime("2011-02-19"))/86400

Expected result:
----------------
I would expect the result to be "1", but it is "1,04166666667"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-25 01:07 UTC] cataphract@php.net
-Status: Open +Status: Bogus
 [2010-10-25 01:07 UTC] cataphract@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

That's due to DST.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Apr 04 06:01:23 2020 UTC