php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53145 echo and print cuts the output
Submitted: 2010-10-24 16:46 UTC Modified: 2010-10-24 19:39 UTC
From: valdisxp1 at inbox dot lv Assigned:
Status: Not a bug Package: *Regular Expressions
PHP Version: 5.2.4 OS: windows 7/ubuntu linux/any?
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: valdisxp1 at inbox dot lv
New email:
PHP Version: OS:

 

 [2010-10-24 16:46 UTC] valdisxp1 at inbox dot lv
Description:
------------
echo and print cuts the output when introduced with  a "<" not following a ">" in 
a variable printed

Test script:
---------------
<?php
$simb="this is broken<NOT";
echo " $simb>";//works with > following
print($simb.">");
echo " $simb";//FAILS
print($simb." ");

?>

Expected result:
----------------
 this is broken<NOT>this is broken<NOT> this is broken<NOTthis is broken<NOT

Actual result:
--------------
 this is broken<NOT>this is broken<NOT> this is broken

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-24 16:51 UTC] valdisxp1 at inbox dot lv
-PHP Version: Irrelevant +PHP Version: 5.2.4
 [2010-10-24 16:51 UTC] valdisxp1 at inbox dot lv
I specified the PHP version
 [2010-10-24 19:39 UTC] cataphract@php.net
-Status: Open +Status: Bogus
 [2010-10-24 19:39 UTC] cataphract@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The output is there; probably your browser isn't showing it. See htmlspecialchars().
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 02:03:35 2021 UTC