php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53032 ODBC and Access request problem
Submitted: 2010-10-09 19:18 UTC Modified: 2020-10-05 08:47 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: david dot marandola at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: ODBC related
PHP Version: 5.2.14 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: david dot marandola at gmail dot com
New email:
PHP Version: OS:

 

 [2010-10-09 19:18 UTC] david dot marandola at gmail dot com
Description:
------------
I'm working with a Access database (.mdb with Access 2003) and I use ODBC to make requests and connection. I'm trying to list my users with a simple SELECT * FROM T_Users, and show the result. I've 3 record in my table but the request send me only the last 2 records.

Test script:
---------------
$sql_select_author	= 'SELECT * FROM T_Users';
$req_select_author	= odbc_exec($dbc, $sql_select_author);
$dat_select_author	= odbc_fetch_array($req_select_author);

while( $data = odbc_fetch_array( $req_select_author ) )
{
  echo $data['FirstName_Users'] .' '. $data['LastName_Users'];
}

Expected result:
----------------
ID - First Name - Last Name
1 - Monsieur - Admin
2 - Tartenpion - Maurice
3 - Dubosc - Franc

Actual result:
--------------
ID - First Name - Last Name
2 - Tartenpion - Maurice
3 - Dubosc - Franc

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2020-10-05 08:47 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2020-10-05 08:47 UTC] cmb@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

$dat_select_author is ignored by the script.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 22 04:01:24 2020 UTC