php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #53028 unable to retrieve process activity of one or more child(ren) in static mode
Submitted: 2010-10-08 20:41 UTC Modified: 2010-12-01 15:18 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:0 (0.0%)
From: iberkner at gmail dot com Assigned: fat (profile)
Status: Closed Package: FPM related
PHP Version: 5.3.3 OS: CentOS 64bit 2.6.18-194.11.4.el5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: iberkner at gmail dot com
New email:
PHP Version: OS:

 

 [2010-10-08 20:41 UTC] iberkner at gmail dot com
Description:
------------
Running php-fpm on several dedicated servers, very busy site, with approx 3mm 
daily page views.  Currently running in pm=static mode with max children set to 
100.  Each system has at least 4GB.  Error notice is set to debug.  

In reviewing the php-fpm error log, several times a day, we'll see this kind of 
error:

Oct 08 12:35:35.574208 [ERROR] pid 1549, 
fpm_pctl_perform_idle_server_maintenance(), line 347: [pool www] unable to 
retrieve process activity of one or more child(ren). Will try again later.

I posted this via the newsgroup and someone suggested I open a bug report, so here 
it is.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-08 21:01 UTC] fat@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: fat
 [2010-10-08 21:01 UTC] fat@php.net
Can you:
- post your full php-fpm.conf
- post the configure options you used to compile PHP.
- post your PHP version

Thx
 [2010-10-09 00:16 UTC] iberkner at gmail dot com
-Status: Feedback +Status: Assigned
 [2010-10-09 00:16 UTC] iberkner at gmail dot com
PHP Version 5.3.3, are you looking for something more specific?
php-fpm configuration file can be found here: http://pastebin.com/cSxYQ0Hu
php configuration options are below:

patch -p1 < suhosin-patch-5.3.3-0.9.10.patch
./configure \
--with-mysqli=mysqlnd \
--with-mysql=mysqlnd \
--enable-fastcgi \
--enable-discard-path \
--enable-force-cgi-redirect \
--enable-fpm \
--enable-cli \
--enable-inline-optimization \
--disable-rpath \
--disable-ipv6 \
--enable-mbstring \
--enable-mbregex \
--enable-sqlite-utf8 \
--with-curl \
--with-zlib \
--enable-shmop \
--with-xsl=shared \
--enable-soap=shared \
--enable-sockets \
--enable-pcntl=shared \
--enable-shared \
--disable-static \
--with-mcrypt \
--with-bz2 \
--with-pcre-dir \
--with-openssl \
--with-pear \
--with-tidy=shared \
--with-gd \
--with-jpeg-dir=/usr/lib64 \
--with-png-dir=/usr/lib64 \
--enable-gd-native-ttf \
--with-freetype-dir \
--enable-exif \
--with-pspell \
--enable-zip \
--enable-ftp \
--with-imap \
--with-kerberos \
--with-imap-ssl \
--enable-bcmath
 [2010-11-11 18:09 UTC] fat@php.net
-Status: Assigned +Status: Feedback
 [2010-11-11 18:09 UTC] fat@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

It should be fixed (revision 305273 and 305264).

Can you please test it ?

Thx
++ Jerome
 [2010-11-11 23:50 UTC] iberkner at gmail dot com
-Status: Feedback +Status: Assigned
 [2010-11-11 23:50 UTC] iberkner at gmail dot com
Thanks, I won't be able to test it for a bit of time.  As soon as I get a chance, 
I'll post an update.
 [2010-11-11 23:53 UTC] fat@php.net
-Status: Assigned +Status: Closed
 [2010-11-11 23:53 UTC] fat@php.net
I close this report. Reopen it if necessary (but it should not).
 [2010-12-01 15:11 UTC] webmaster_apc at colnect dot com
Please re-open

I see these issues on a server which isn't that busy

Nov 30 13:04:01.097751 [ERROR] [pool www] unable to retrieve process activity of one or more child(ren). Will try again later.
Nov 30 15:29:36.477754 [ERROR] [pool www] unable to retrieve process activity of one or more child(ren). Will try again later.
Nov 30 15:54:03.597803 [ERROR] [pool www] unable to retrieve process activity of one or more child(ren). Will try again later.
Nov 30 16:52:11.347780 [ERROR] [pool www] unable to retrieve process activity of one or more child(ren). Will try again later.


Using latest Gentoo with PHP 5.3.3-r3
 [2010-12-01 15:18 UTC] fat@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

This has been since corrected in SVN. Please try a snapshot or wait for 5.3.4 (rc2 
or final).
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC