php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #53027 date_moonrise, date_moonset, and date_moon_info for calculating moonrise
Submitted: 2010-10-08 20:06 UTC Modified: 2017-03-24 06:42 UTC
Votes:28
Avg. Score:4.2 ± 0.8
Reproduced:21 of 21 (100.0%)
Same Version:10 (47.6%)
Same OS:13 (61.9%)
From: sec at mboca dot com Assigned:
Status: Wont fix Package: Date/time related
PHP Version: 5.2.14 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
35 + 20 = ?
Subscribe to this entry?

 
 [2010-10-08 20:06 UTC] sec at mboca dot com
Description:
------------
I did a search thru all places on php.net for moonrise and moonset
functions or any comments about moonrise and moonset.
I can not find anything about moonrise and moonset.
I am not sure where to submit my ideas and suggestions.
I would like to suggest to php developers to add in the moonrise and
moonset functions.
I think the moonrise and moonset functions should be added in php.
date_moonrise
date_moonset
date_moon_info
those functions would be great to have in future version of php.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-01 15:20 UTC] jani@php.net
-Package: Unknown/Other Function +Package: Date/time related -Operating System: linux and windows +Operating System:
 [2010-12-01 15:20 UTC] jani@php.net
-Summary: [IDEA] date_moonrise, date_moonset, and date_moon_info for calculating moonrise +Summary: date_moonrise, date_moonset, and date_moon_info for calculating moonrise
 [2017-03-24 06:42 UTC] heiglandreas@php.net
-Status: Open +Status: Wont fix
 [2017-03-24 06:42 UTC] heiglandreas@php.net
As the algoithms seem to be available and there already is at least one implementation in userland (https://dxprog.com/entry/calculate-moon-rise-and-set-in-php/) I'll close this issue!

Due to the fact that this is the only request for moon-dates and there aren'T many "Me too" comments I'd say it's not a widely required feature and therefore a userland-implementation should be better suited (and also be better maintained)
 [2017-07-19 22:25 UTC] max at acuparse dot com
I would me too this only because the current user-land implementation is licensed under the GNU GPLv3. It also does not appear to be maintained. Attempts to contact the author have been unsuccessful. This one feature in my app forces me to use at least GPLv3 to release, with it included.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Aug 21 11:01:27 2019 UTC