php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52904 json_decode don't make good object
Submitted: 2010-09-22 09:52 UTC Modified: 2010-09-22 09:57 UTC
From: nadavvin at gmail dot com Assigned:
Status: Not a bug Package: JSON related
PHP Version: 5.3.3 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nadavvin at gmail dot com
New email:
PHP Version: OS:

 

 [2010-09-22 09:52 UTC] nadavvin at gmail dot com
Description:
------------
php > echo $e
php > ;
{"a":1,"b":2}
php > $f = json_decode($e);
php > var_dump($f);
object(stdClass)#2 (2) {
["a"]=>
int(1)
["b"]=>
int(2)
}
php > $g=(array)$f;
php > echo $f['a'];
PHP Fatal error: Cannot use object of type stdClass as array in php shell code on line 1


Expected result:
----------------
php > $a=array('a'=>1,'b'=>2);
php > $b = (object)$a;
php > $c = (array)$b;
php > var_dump($a);
array(2) {
["a"]=>
int(1)
["b"]=>
int(2)
}
php > echo $c['a'];
1

Actual result:
--------------
PHP Fatal error: Cannot use object of type stdClass as array in php shell code on line 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-22 09:56 UTC] salathe@php.net
-Status: Open +Status: Feedback
 [2010-09-22 09:56 UTC] salathe@php.net
Surely your last console line should be: echo $g['a'];   (considering that $f is 
the object, and $g the array)?
 [2010-09-22 09:57 UTC] aharvey@php.net
-Status: Feedback +Status: Open
 [2010-09-22 09:57 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2010-09-22 09:57 UTC] aharvey@php.net
-Status: Open +Status: Bogus
 [2010-09-22 09:57 UTC] aharvey@php.net
.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 01:01:23 2020 UTC