php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #52857 Access to gdImageSetClip() and gdImageGetClip()
Submitted: 2010-09-16 03:41 UTC Modified: 2016-09-24 13:44 UTC
Votes:27
Avg. Score:4.6 ± 0.7
Reproduced:26 of 26 (100.0%)
Same Version:25 (96.2%)
Same OS:19 (73.1%)
From: ljb9832 at pobox dot com Assigned: cmb (profile)
Status: Closed Package: GD related
PHP Version: 5.3.3 OS: N/A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
41 + 29 = ?
Subscribe to this entry?

 
 [2010-09-16 03:41 UTC] ljb9832 at pobox dot com
Description:
------------
Since 2.0.12, libgd has supported a user-defined clipping rectangle using gdImageSetClip() and gdImageGetClip(). This clips all drawing operations to the specified area, and is a very useful capability. However, PHP does not expose these functions. Please consider adding a PHP function or functions to allow setting and getting the clipping boundaries. This could be two functions, imagesetclip($image, $x1, $y1, $x2, $y2) and imagegetclip($image), or a single function imageclip($image, [$x1, $y1, $x2, $y2]) which sets the clipping boundary if the arguments are provided, and returns the new or current boundary.


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-07-23 14:07 UTC] cmb@php.net
-Summary: Access to gdImageSetClip() +Summary: Access to gdImageSetClip() and gdImageGetClip()
 [2016-07-23 14:16 UTC] cmb@php.net
I've submitted a respective PR
 [2016-09-24 13:44 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2016-09-24 13:44 UTC] cmb@php.net
The PR has been merged. imagesetclip() and imagegetclip() will be
available as of PHP 7.2.0.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 00:03:39 2021 UTC