php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52837 function implode can't do well with character '&'
Submitted: 2010-09-14 11:09 UTC Modified: 2010-09-14 11:11 UTC
From: frankyue1019 at gmail dot com Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.2SVN-2010-09-14 (SVN) OS: ubuntu 10.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: frankyue1019 at gmail dot com
New email:
PHP Version: OS:

 

 [2010-09-14 11:09 UTC] frankyue1019 at gmail dot com
Description:
------------
<?php
$array = array('lastname', 'email', 'phone');
$comma_separated = implode('&',$array);
echo strlen($comma_separated);
echo $comma_separated;
?>

Expected result:
----------------
web should print this:
20lastname&email&phone

Actual result:
--------------
web just print this:
20lastname&email

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-14 11:11 UTC] aharvey@php.net
-Status: Open +Status: Bogus
 [2010-09-14 11:11 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 25 13:01:25 2020 UTC