php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52753 With proposed fix: use of '/' in httpd.conf causes apache crash
Submitted: 2010-08-31 21:05 UTC Modified: 2010-12-22 17:03 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:3 (100.0%)
From: jrompre at gmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.3.3 OS: Win/XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
41 - 6 = ?
Subscribe to this entry?

 
 [2010-08-31 21:05 UTC] jrompre at gmail dot com
Description:
------------
This is easy, and I fixed it myself. I installed the V6 thread-safe version (Windows) with the Apache2.2x module config option, and restarted Apache, which caused an Apache crash. The problem was caused by the httpd.conf added fragment which wrongly uses the Unix path element separator - changing the '/' to a '\' fixed the problem, and I could also see the test hello.php output as expected.

#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:/Program Files/PHP/"
LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

(change all '/' to '\' to prevent crashes in Windows)

Test script:
---------------
N/A

Expected result:
----------------
See description

Actual result:
--------------
See description

Patches

bugfixpath (last revision 2010-08-31 19:07 UTC by jrompre at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-02 11:09 UTC] kalle@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: pajoye
 [2010-09-02 11:09 UTC] kalle@php.net
Seems like its intended in the win-installer, see:
PHPInstallerScripts{XXX}.vbs

strPHPPath = Replace(strInstallDir,"\","/")

Guess that should be reverted, but I don't have karma for that part. Pierre? :)
 [2010-09-02 11:10 UTC] kalle@php.net
-Package: Apache2 related +Package: Windows Installer
 [2010-09-02 11:28 UTC] kalle@php.net
-Status: Assigned +Status: Open -Assigned To: pajoye +Assigned To:
 [2010-11-06 17:21 UTC] felipe@php.net
-Assigned To: +Assigned To: jmertic
 [2010-12-22 17:03 UTC] jmertic@php.net
Automatic comment from SVN on behalf of jmertic
Revision: http://svn.php.net/viewvc/?view=revision&revision=306574
Log: Bug 52753 - Comment out changing '\' to '/' in the path to the PHP dll/exe since it causes an invalid http.conf file
 [2010-12-22 17:03 UTC] jmertic@php.net
-Status: Assigned +Status: Closed
 [2010-12-22 17:03 UTC] jmertic@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 08:05:44 2022 UTC