|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52705 error - missing zlib.dll
Submitted: 2010-08-26 05:40 UTC Modified: 2010-08-26 19:27 UTC
From: pfenderd at bellsouth dot net Assigned:
Status: Duplicate Package: CGI/CLI related
PHP Version: 5.2.14 OS: windows vista ultimate 32-bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: pfenderd at bellsouth dot net
New email:
PHP Version: OS:


 [2010-08-26 05:40 UTC] pfenderd at bellsouth dot net
Running PHP in command-line mode, causes fatal error everytime.
Doing "php -v", causes error "php.exe - Unable to Locate Component".
Detail "This application has failed to start because zlib.dll was not found. Re-installing the application may fix this problem".

This error occurs with the php.ini file created during installation of PHP.
Changing the php.ini file to log the errors did not show any errors. Obviously, the fatal error occurred during program initialization. Trying different arguments to php did not change the problem.  Everything was working properly with PHP version 5.2.6.  Now it never works.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-26 10:43 UTC]
Can you try again please using bins from
 [2010-08-26 10:43 UTC]
-Status: Open +Status: Feedback
 [2010-08-26 18:10 UTC] pfenderd at bellsouth dot net
-Summary: error - missin zlib.dll +Summary: error - missing zlib.dll -Status: Feedback +Status: Open
 [2010-08-26 18:10 UTC] pfenderd at bellsouth dot net
The problem with the command-line mode was solved with the installation using 
"php-5.2.14-Win32-VC6-x86.msi" from the website.

However, this did not fix the bug reported as #52704.
 [2010-08-26 19:27 UTC]
-Status: Open +Status: Duplicate
 [2010-08-26 19:27 UTC]
There is another report about this issue, solved too. It was the curl extension who was responsible for this error.

However the other report you mention is not related to this issue.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 07:01:31 2024 UTC