php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5269 apache will not run if I compile with PHP with oracle support
Submitted: 2000-06-29 15:02 UTC Modified: 2006-07-17 09:04 UTC
From: abuxbaum at concretemedia dot com Assigned:
Status: Not a bug Package: OCI8 related
PHP Version: 4.0 Release Candidate 2 OS: Linux 2.2.14-5.0smp #1 SMP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: abuxbaum at concretemedia dot com
New email:
PHP Version: OS:

 

 [2000-06-29 15:02 UTC] abuxbaum at concretemedia dot com
It is version PHP 4.0.0 

If I compile with PHP with oracle support as follow  =  configure --prefix=/opt/PHP4 --with-apxs=/usr/sbin/apxs --with-mysql --with-oci8=/u01/app/oracle/product/8.1.6

apache will not run it will not even log anything to error.log what can it do to resolve this ?????

Thanks,
Abraham

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-26 02:07 UTC] waldschrott@php.net
Please verify that it?s still happening using the latest version of PHP (release 4.0.1pl2 or CVS).
 [2000-07-26 13:39 UTC] thies@php.net
    please relink your apache adding -lpthread to the LDFLAGS.
 
    the problem here is that a executable thats *not* linked
    agains -lpthread cannot load a shared library that is liked
    against -lpthread. (libphp4.so - linked against -lclntsh
    linked against -lpthread).
 
    this is a glibc-2.1 bug that supposed to be finxed in 2.2 (i
    heard).

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 14:01:24 2020 UTC