php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #52619 Incorrect function return type.
Submitted: 2010-08-16 14:54 UTC Modified: 2010-08-16 15:47 UTC
From: hyounis at yubb-software dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hyounis at yubb-software dot com
New email:
PHP Version: OS:

 

 [2010-08-16 14:54 UTC] hyounis at yubb-software dot com
Description:
------------
The return type of function strpos is incorrectly listed as int in the manual, while it should be listed as 'mixed' since it may return an integer or a boolean value.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-16 15:47 UTC] rquadling@php.net
-Status: Open +Status: Bogus
 [2010-08-16 15:47 UTC] rquadling@php.net
We do not include the failure result in the return type.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 16:01:27 2020 UTC