php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52421 Installer doesn't obey chosen config options
Submitted: 2010-07-23 22:49 UTC Modified: 2015-06-09 16:00 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:2 (66.7%)
From: davidmedina5 at gmail dot com Assigned: cmb (profile)
Status: Wont fix Package: Windows Installer
PHP Version: 5.3.3 OS: Windows XP Professional SP3 x86
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: davidmedina5 at gmail dot com
New email:
PHP Version: OS:

 

 [2010-07-23 22:49 UTC] davidmedina5 at gmail dot com
Description:
------------
I just downloaded latest versions of Apache HTTPd (2.2.15 with OpenSSL 0.9.8m-r2) and PHP (5.3.3, VC6, thread safe).
Installed HTTPd from .msi and works fine. Then installed PHP from .msi and in the screen where you can select to configure PHP as a webserver module I chose "Do not setup a web server". After copying the files, the installer shows two warnings:
1) "Error trying to access httpd.conf file. You will need to manually configure the web server."
2) "Error trying access the local web service: GetObject Failed. You will need to manually configure the web server."
The installer shouldn't try to access httpd.conf if "Do not setup a web server" is selected. However, PHP seems to work fine after configuring it manually in httpd.conf.

There are similar bugs, closed some years ago (39781 and 42257) but seems the misbehaviour persists. I've also noticed this before with PHP 5.3.2 and 5.2.x installers.


By the way, I think there's a "to" missing in the second message (before "access").


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-23 23:14 UTC] davidmedina5 at gmail dot com
-Summary: Installer issues warnings +Summary: Installer doesn't obey chosen config options
 [2010-07-23 23:14 UTC] davidmedina5 at gmail dot com
Edited the summary to better describe the bug.
 [2015-06-09 16:00 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2015-06-09 16:00 UTC] cmb@php.net
This ticket is obsolete, because Microsoft installer binaries
(.msi) are not distributed anymore as of PHP 5.4.0.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 19:01:23 2020 UTC