php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5236 dlerror - conflicting declerations
Submitted: 2000-06-27 16:39 UTC Modified: 2001-05-27 21:21 UTC
From: darren at bmv dot state dot me dot us Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.0.0 Release/ 4.0.4pl1 OS: AIX 4.2.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: darren at bmv dot state dot me dot us
New email:
PHP Version: OS:

 

 [2000-06-27 16:39 UTC] darren at bmv dot state dot me dot us
A very simplue configuration... --enable-mysql --with-apxs

apache 1.3.12
gcc 2.95.1 and 2.95.2

I've seen this same error detailed numerous times in the past year.

Make results in....

/bin/sh /home/darren/Temp/php-4.0.0/libtool --silent --mode=compile gcc -DHAVE_C
ONFIG_H -I. -I/home/darren/Temp/php-4.0.0/sapi/apache -I/home/darren/Temp/php-4.
0.0 -I/usr/local/apache/include -I/home/darren/Temp/php-4.0.0/Zend -I/home/darre
n/Temp/php-4.0.0 -I/home/darren/Temp/php-4.0.0/ext/mysql/libmysql -I/home/darren
/Temp/php-4.0.0/ext/xml/expat/xmltok -I/home/darren/Temp/php-4.0.0/ext/xml/expat
/xmlparse  -DXML_BYTE_ORDER=21 -O2 -g -Wall  -c sapi_apache.c
In file included from /usr/local/apache/include/ap_config.h:116,
                 from /usr/local/apache/include/httpd.h:71,
                 from sapi_apache.c:32:
/usr/local/apache/include/os.h:122: conflicting types for `dlerror'
/usr/include/dlfcn.h:35: previous declaration of `dlerror'
gmake[3]: *** [sapi_apache.lo] Error 1
gmake[3]: Leaving directory `/home/darren/Temp/php-4.0.0/sapi/apache'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/home/darren/Temp/php-4.0.0/sapi/apache'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/home/darren/Temp/php-4.0.0/sapi'
gmake: *** [all-recursive] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-26 01:54 UTC] waldschrott@php.net
Please verify that it?s still happening using the latest version of PHP (release 4.0.1pl2 or CVS).
 [2000-08-02 17:49 UTC] waldschrott@php.net
user feedback:

Yes, it is still a problem. See Bug #5534

Note that I was able to get around this problem by modifying
apache's
os.h file an changing

const char *dlerror(void);

to

char *dlerror(void);

The change really should be made to php however. Unless it
is a bug in
apache of course. I'm not sure where the fault lies for this
one other then
thinking that php needs to use the apache stuff as it is
installed by
apache.

 [2000-11-01 02:46 UTC] andi@php.net
Does this still happen with 4.0.3pl1?
It does seem like an Apache problem though.
 [2000-12-07 11:15 UTC] sniper@php.net
No feedback.
 [2001-04-23 16:42 UTC] darren at bmv dot state dot me dot us
This is still a problem (php 4.0.4pl1 & apache 1.3.19). Same work around.


 [2001-05-27 21:21 UTC] sniper@php.net
This is Apache bug. 

--Jani

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 07:03:33 2021 UTC