php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52305 php5_module interpret .sma file
Submitted: 2010-07-11 15:15 UTC Modified: 2010-07-11 19:43 UTC
From: jinmoku at hotmail dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: Irrelevant OS: *nix
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jinmoku at hotmail dot com
New email:
PHP Version: OS:

 

 [2010-07-11 15:15 UTC] jinmoku at hotmail dot com
Description:
------------
php5_module interpret .sma file


tmp fix :
AddType text/plain .sma

Test script:
---------------
create index.php.sma file with :

<?php
echo `printenv`;

Expected result:
----------------
<?php
echo `printenv`;

Actual result:
--------------
PATH=/usr/bin:/bin:/usr/sbin:/sbin
PWD=/Library/WebServer/Documents/test
SHLVL=1
_=/usr/bin/printenv

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-11 19:43 UTC] johannes@php.net
-Status: Open +Status: Bogus
 [2010-07-11 19:43 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

PHP parses what what the web server tells it. Fix your server's configuration.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Feb 29 18:01:31 2024 UTC