php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52276 Odd session.gc_maxlifetime value
Submitted: 2010-07-07 17:50 UTC Modified: 2011-06-06 02:02 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: sworddragon2 at aol dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.3.2 OS: Windows XP Professional SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sworddragon2 at aol dot com
New email:
PHP Version: OS:

 

 [2010-07-07 17:50 UTC] sworddragon2 at aol dot com
Description:
------------
The default value of session.gc_maxlifetime is 1440 seconds which are 24 minutes. Is this really the correct value or thought the programmer that these are minutes because 1440 minutes are 24 hours? Maybe the value should be changed to 86400 seconds (this are 1440 minutes) or to another clearer value.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-06-05 23:42 UTC] iliaa@php.net
-Status: Open +Status: Bogus
 [2011-06-05 23:42 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

This is the intended value (24 minutes).
 [2011-06-06 02:02 UTC] sworddragon2 at aol dot com
Maybe 24 minutes are intended but I can't find any information for the reason in the documentation.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 01:05:44 2022 UTC