php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #52216 Interval spec duplicates the identifier for Minutes and Months (M)
Submitted: 2010-07-01 07:11 UTC Modified: 2010-07-01 10:46 UTC
From: elliot dot a at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: elliot dot a at gmail dot com
New email:
PHP Version: OS:

 

 [2010-07-01 07:11 UTC] elliot dot a at gmail dot com
Description:
------------
Should the minute identifier in the documentation be I in keeping with the time formatting standards? Otherwise the M identifier is ambiguous.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-01 07:19 UTC] aharvey@php.net
-Status: Open +Status: Wont fix
 [2010-07-01 07:19 UTC] aharvey@php.net
The string representation for input to the DateInterval class is actually the ISO 8601 duration specification, which is a standard far beyond the world of PHP. Within that standard, the M is not ambiguous: if it's before the T in the input, then it's months, if it's after, then it's minutes (since the post-T section is the time specification).
 [2010-07-01 10:46 UTC] rquadling@php.net
-Status: Wont fix +Status: Bogus
 [2010-07-01 10:46 UTC] rquadling@php.net
This is not a "won't fix bug". It is not a bug at all.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 22 20:01:28 2020 UTC