php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #52203 Builth in CSSQuery please!
Submitted: 2010-06-29 13:29 UTC Modified: 2021-08-05 12:28 UTC
Votes:7
Avg. Score:4.4 ± 1.4
Reproduced:5 of 5 (100.0%)
Same Version:1 (20.0%)
Same OS:1 (20.0%)
From: taknegaar at gmail dot com Assigned: cmb (profile)
Status: Wont fix Package: *XML functions
PHP Version: 5.3.2 OS: BSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: taknegaar at gmail dot com
New email:
PHP Version: OS:

 

 [2010-06-29 13:29 UTC] taknegaar at gmail dot com
Description:
------------
CSSQuery : 

jQuery selector like for html tag select.

Ease the selection of DOMElements from an HTML document using CSS selectors instead of XPath. 


http://querypath.org/


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-08-05 12:28 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2021-08-05 12:28 UTC] cmb@php.net
This is unlikely to happen, since libxml2 doesn't support CSS
selectors, and given that there are userland libraries which
support this[1], the RFC process[2] is required, and the RFC would
have to make a strong case why this should be bundled with
php-src.

[1] <https://packagist.org/?query=cssselector>
[2] <https://wiki.php.net/rfc/howto>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 18 03:03:36 2021 UTC