php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #52200 While configure pop's error "configure: error: Cannot find php_pdo_driver.h"
Submitted: 2010-06-28 21:06 UTC Modified: 2013-02-18 00:34 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: mikhail dot v dot gavrilov at gmail dot com Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 5.3.3RC1 OS: Linux Fedora 13
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mikhail dot v dot gavrilov at gmail dot com
New email:
PHP Version: OS:

 

 [2010-06-28 21:06 UTC] mikhail dot v dot gavrilov at gmail dot com
Description:
------------
Try build 5.3.3RC1 also 5.3.2 from sources, during configure process pop's error: 
"configure: error: Cannot find php_pdo_driver.h"

Installed packages: libxml2-devel openssl-devel bzip2-devel curl-devel libjpeg-
devel libpng-devel libevent-devel freetype-devel t1lib-devel libc-client-devel 
libmcrypt-devel mysql-devel libevent-devel

What is wrong?

Test script:
---------------
./configure --with-fpm --with-libevent=shared --with-mcrypt --enable-mbstring --with-openssl --with-mysql --with-mysql-sock --with-gd --with-jpeg-dir=/usr/lib --enable-gd-native-ttf --with-sqlite=shared --with-pdo-mysql --with-libxml-dir=/usr/lib --with-mysqli=/usr/bin/mysql_config --with-curl --enable-zip --with-bz2 --enable-soap=shared --with-imap=shared --with-imap-ssl --enable-sockets --with-zlib --enable-exif --enable-ftp --with-iconv --with-gettext --enable-gd-native-ttf --with-t1lib=/usr --with-freetype-dir=/usr --with-kerberos --prefix=/usr/local/php --with-fpm-user=www-data --with-fpm-group=www-data

also try simple configure without any param's, but result are similar.

./configure


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-07-15 01:55 UTC] kalle@php.net
If I remember right, then there was a similar issue with one of the PDO includes if not the same when a user was compiling where one of the directories had a space in it in the path, is that the case here?
 [2010-07-15 01:56 UTC] kalle@php.net
-Status: Open +Status: Feedback
 [2013-02-18 00:34 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 22:01:28 2024 UTC