php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #52076 rename Australian time zone abbreviations to avoid ambiguity
Submitted: 2010-06-13 21:14 UTC Modified: 2010-06-13 21:34 UTC
Votes:2
Avg. Score:3.5 ± 0.5
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: dfsdf at mailinator dot com Assigned:
Status: Wont fix Package: Date/time related
PHP Version: 5.3.2 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dfsdf at mailinator dot com
New email:
PHP Version: OS:

 

 [2010-06-13 21:14 UTC] dfsdf at mailinator dot com
Description:
------------
In PHP, formatting a date with 'T' for an Australian East or Central time zone generates "EST" and "CST" respectively. Since time zone calculations often involve global context, it is confusing to have multiple definitions of EST and CST, as EST is also used for Eastern Standard Time (US) and CST for Central Standard Time (US).

To quote Wikipedia:

"The proper names of Australia's time zones vary. In international contexts they are often called Australian Western Standard Time (AWST), Australian Central Standard Time (ACST), and Australian Eastern Standard Time (AEST). In domestic contexts the leading "Australian" is often dropped."


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-13 21:34 UTC] derick@php.net
-Status: Open +Status: Wont fix
 [2010-06-13 21:34 UTC] derick@php.net
We are consuming another data source here. If you want to get this changed, you need to take this up with the folks at http://www.twinsun.com/tz/tz-link.htm through their mailing-list. I can however tell you, that you probably have little success convincing them without proper backed-up governmental descriptions.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 22:04:07 2022 UTC