php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51734 cairo_font_options_object undeclared (first use in this function)
Submitted: 2010-05-04 02:04 UTC Modified: 2010-05-04 16:52 UTC
From: scorninpc at gmail dot com Assigned:
Status: Not a bug Package: PHP-GTK related
PHP Version: 5.3.2 OS: Ubuntu 10.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: scorninpc at gmail dot com
New email:
PHP Version: OS:

 

 [2010-05-04 02:04 UTC] scorninpc at gmail dot com
Description:
------------
I'm trying compile php-gtk from SVN and PHP 5.3.2-1ubuntu4 with Suhosin-Patch (cli) (built: Apr  9 2010 08:23:39)

I can't compile without cairo, and after compile cairo, i get this error:


root@anne:~/Projetos/projetos/php-gtk/php-gtk# make
/bin/bash /home/scorninpc/Projetos/projetos/php-gtk/php-gtk/libtool --mode=compile cc  -Iext/gtk+/ -I/home/scorninpc/Projetos/projetos/php-gtk/php-gtk/ext/gtk+/ -DPHP_ATOM_INC -I/home/scorninpc/Projetos/projetos/php-gtk/php-gtk/include -I/home/scorninpc/Projetos/projetos/php-gtk/php-gtk/main -I/home/scorninpc/Projetos/projetos/php-gtk/php-gtk -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/php5/ext/cairo -I/usr/include/libglade-2.0 -I/usr/include/libxml2  -DHAVE_CONFIG_H  -g -O2 -DHAVE_CAIRO   -c ext/gtk+/gen_gdk.c -o ext/gtk+/gen_gdk.lo 
libtool: compile:  cc -Iext/gtk+/ -I/home/scorninpc/Projetos/projetos/php-gtk/php-gtk/ext/gtk+/ -DPHP_ATOM_INC -I/home/scorninpc/Projetos/projetos/php-gtk/php-gtk/include -I/home/scorninpc/Projetos/projetos/php-gtk/php-gtk/main -I/home/scorninpc/Projetos/projetos/php-gtk/php-gtk -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/php5/ext/cairo -I/usr/include/libglade-2.0 -I/usr/include/libxml2 -DHAVE_CONFIG_H -g -O2 -DHAVE_CAIRO -c ext/gtk+/gen_gdk.c  -fPIC -DPIC -o ext/gtk+/.libs/gen_gdk.o
ext/gtk+/gdk-2.10.overrides: In function ‘zim_GdkScreen_set_font_options’:
ext/gtk+/gdk-2.10.overrides:15: error: ‘cairo_font_options_object’ undeclared (first use in this function)
ext/gtk+/gdk-2.10.overrides:15: error: (Each undeclared identifier is reported only once
ext/gtk+/gdk-2.10.overrides:15: error: for each function it appears in.)
ext/gtk+/gdk-2.10.overrides:15: error: ‘fobj’ undeclared (first use in this function)
ext/gtk+/gdk-2.10.overrides:20: error: expected expression before ‘)’ token
ext/gtk+/gdk-2.10.overrides: In function ‘zim_GdkScreen_get_font_options’:
ext/gtk+/gdk-2.10.overrides:31: error: ‘cairo_font_options_object’ undeclared (first use in this function)
ext/gtk+/gdk-2.10.overrides:31: error: ‘fobj’ undeclared (first use in this function)
ext/gtk+/gdk-2.10.overrides:39: error: expected expression before ‘)’ token
make: ** [ext/gtk+/gen_gdk.lo] Erro 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-05-04 02:46 UTC] auroraeosrose@php.net
-Status: Open +Status: Feedback
 [2010-05-04 02:46 UTC] auroraeosrose@php.net
What version of PECL Cairo are you compiling against?

cairo_font_options_object is from cairo_api.h

Please make sure you're using the latest version of the PECL cairo extension
 [2010-05-04 02:48 UTC] scorninpc at gmail dot com
-Status: Feedback +Status: Open
 [2010-05-04 02:48 UTC] scorninpc at gmail dot com
i've compiled from

svn co svn://whisky.macvicar.net/php-cairo cairo

it don't work?
 [2010-05-04 02:51 UTC] auroraeosrose@php.net
-Status: Open +Status: Feedback
 [2010-05-04 02:51 UTC] auroraeosrose@php.net
No - that's a VERY old version of the code

The new location of the source code is http://svn.php.net/viewvc/pecl/cairo

http://pecl.php.net/package/cairo

Try the latest version please and see if the error still occurs
 [2010-05-04 02:59 UTC] scorninpc at gmail dot com
Ok, I compiled this version and php-gtk works fine, but i can't run cairo_support.php

root@anne:~/Projetos/projetos/php-gtk/php-gtk# php demos/examples/cairo_support.php 
php: symbol lookup error: /usr/lib/php5/20090626+lfs/php_gtk.so: undefined symbol: php_cairo_get_context_ce
root@anne:~/Projetos/projetos/php-gtk/php-gtk#

this sample don't work with this version?
 [2010-05-04 16:45 UTC] auroraeosrose@php.net
I need you to do php -m

You MUST have the PECL cairo extension loaded, and it must be loaded before PHP-GTK

Are both in that output?
 [2010-05-04 16:50 UTC] scorninpc@php.net
Oh, i think its not a bug, this is a problem with cairo instalation, becase coping module manualy it's work.

I dont know if I can use this thread to talk about Glade and Scintilla.

If not, it's solved (closed)

Ty alot and sorry for my english =)
 [2010-05-04 16:52 UTC] auroraeosrose@php.net
-Status: Feedback +Status: Bogus
 [2010-05-04 16:52 UTC] auroraeosrose@php.net
Support issue - bogus

Ask support questions on the list php-gtk general mailing list please, you might have to wait a day but you will get a response
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 01 08:01:24 2020 UTC