php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5171 Impossible to use OCI Cursors
Submitted: 2000-06-21 16:23 UTC Modified: 2006-07-17 08:45 UTC
From: alex dot scotti at tiscalinet dot it Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.0 Release OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alex dot scotti at tiscalinet dot it
New email:
PHP Version: OS:

 

 [2000-06-21 16:23 UTC] alex dot scotti at tiscalinet dot it
Trying to pass cursors this happens:

Package  description:

CREATE OR REPLACE PACKAGE NEST.META AS
	TYPE REF_C IS REF CURSOR RETURN NEST.STRUTTURA%ROWTYPE;
	PROCEDURE STRUTTURA_C(C IN OUT REF_C);
...........
CREATE OR REPLACE PACKAGE BODY NEST.META AS
	PROCEDURE STRUTTURA_C(C IN OUT REF_C)
	IS
	BEGIN
		OPEN C FOR SELECT * FROM NEST.STRUTTURA;
	END STRUTTURA_C;
.............

Script:
<?
OCIInternalDebug(1);
$c=OCILogon($u, $p, 'utf8');
$curs=OCINewCursor($c);
$stmt=OCIParse($c, "BEGIN NEST.META.STRUTTURA_C(:CURS); END;");
OCIBindByName($stmt, ":CURS", $curs, -1, OCI_B_CURSOR);
OCIExecute($stmt);
OCIExecute($curs);
OCIFetch($curs); 	
?>

Output:
OCIDebug: _oci_open_server new conn=0 dname=utf8
OCIDebug: _oci_open_session new sess=2 user=nest
OCIDebug: oci_do_connect: id=3
OCIDebug: oci_parse "" id=4 conn=3
OCIDebug: oci_parse "BEGIN NEST.META.STRUTTURA_C(:CURS); END;" id=5 conn=3

Warning: OCIFetch: ORA-24374: define not done before fetch or execute and fetch in D:\WWW\nest\catalogo\varie\prove.php on line 9
OCIDebug: START php_rshutdown_oci
OCIDebug: END php_rshutdown_oci
OCIDebug: START _oci_stmt_list_dtor: id=5 last_query="BEGIN NEST.META.STRUTTURA_C(:CURS); END;"
OCIDebug: _oci_bind_hash_dtor:
OCIDebug: END _oci_stmt_list_dtor: id=5
OCIDebug: START _oci_stmt_list_dtor: id=4 last_query=""
OCIDebug: END _oci_stmt_list_dtor: id=4
OCIDebug: START _oci_conn_list_dtor: id=3
OCIDebug: END _oci_conn_list_dtor: id=3
OCIDebug: _oci_close_session: logging-off sess=2
OCIDebug: START _oci_close_server: detaching conn=1 dbname=utf8

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-07 08:03 UTC] thies@php.net
cannot reproduce - please reopen if problem persists.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Aug 15 00:05:45 2022 UTC