php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51704 bug with mktime function
Submitted: 2010-04-30 15:02 UTC Modified: 2010-04-30 15:05 UTC
From: nair_santosh at hotmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: Irrelevant OS: windows/linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
22 + 48 = ?
Subscribe to this entry?

 
 [2010-04-30 15:02 UTC] nair_santosh at hotmail dot com
Description:
------------
I wrote a function to return an array that will consist of the key-value pair of all the month-number and 3 letter suffix of the month as

1=>Jan
2=>Feb
3=>Mar
so on...
The problem is the function works on all days except on month ends (for ex 31jan, 28feb, 31mar so on ) will display
Mar of the key 2 and 3 as well


Test script:
---------------
please change the system date to a month end before running this code
for ex i tested this code on 30 apt 2010

echo "<br>";
echo date("M",mktime(0,0,0,date(2),date("d"),date("Y")));
echo "<br>";
echo date("M",mktime(0,0,0,date(3),date("d"),date("Y")));
echo "<br>";



Expected result:
----------------
Mar
Mar


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-30 15:05 UTC] derick@php.net
-Status: Open +Status: Bogus
 [2010-04-30 15:05 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 16:01:32 2024 UTC