php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51646 ReflectionClass didn't show $length property from DOMNodeList
Submitted: 2010-04-23 14:56 UTC Modified: 2010-04-23 15:48 UTC
From: oleg at elifantiev dot ru Assigned:
Status: Not a bug Package: Class/Object related
PHP Version: 5.2.13 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: oleg at elifantiev dot ru
New email:
PHP Version: OS:

 

 [2010-04-23 14:56 UTC] oleg at elifantiev dot ru
Description:
------------
Reflection didn't show all information on some php-internal classes (i.e. DOMNodeList).

It hides some properties (i.e. DOMNodeList::$lenght)

Test script:
---------------
<?
$dt = new ReflectionClass("DOMNodeList");
echo $dt;
?>

Expected result:
----------------
Class [ <internal:dom> <iterateable> class DOMNodeList ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [0] {
// want to see $length property here
  }

  - Methods [1] {
    Method [ <internal:dom> public method item ] {

      - Parameters [1] {
        Parameter #0 [ <required> $index ]
      }
    }
  }
}

Actual result:
--------------
Class [ <internal:dom> <iterateable> class DOMNodeList ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [0] {
  }

  - Methods [1] {
    Method [ <internal:dom> public method item ] {

      - Parameters [1] {
        Parameter #0 [ <required> $index ]
      }
    }
  }
}

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-23 15:48 UTC] rrichards@php.net
-Status: Open +Status: Bogus
 [2010-04-23 15:48 UTC] rrichards@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

duplicate of bug #48527
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Mar 05 04:01:23 2021 UTC