php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51643 ICONV transliteration bug
Submitted: 2010-04-23 11:17 UTC Modified: 2010-05-12 12:08 UTC
From: olegs at brandos dot com Assigned:
Status: Not a bug Package: ICONV related
PHP Version: 5.2.13 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: olegs at brandos dot com
New email:
PHP Version: OS:

 

 [2010-04-23 11:17 UTC] olegs at brandos dot com
Description:
------------
Transliteration of ø char (at least)

Test script:
---------------
iconv('UTF-8', 'ASCII//TRANSLIT', 'Støvler & Støvletter');

Expected result:
----------------
'Stovler & Stovletter'

Actual result:
--------------
'Stvler & Stvletter'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-05-12 12:08 UTC] mike@php.net
-Status: Open +Status: Bogus
 [2010-05-12 12:08 UTC] mike@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

$ iconv -f utf8 -t ascii//translit <<<'Støvler & Støvletter' | hexdump -C
00000000  53 74 3f 76 6c 65 72 20  26 20 53 74 3f 76 6c 65  |St?vler & St?vle|
00000010  74 74 65 72 0a                                    |tter.|
00000015
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 17:03:36 2021 UTC