php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51628 I noticed that is hard to find the translation of the PHP manual in Spanish
Submitted: 2010-04-22 05:28 UTC Modified: 2010-06-05 17:25 UTC
From: yago@php.net Assigned: bjori (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yago@php.net
New email:
PHP Version: OS:

 

 [2010-04-22 05:28 UTC] yago@php.net
Description:
------------
Hi, 
We are been working in the Spanish translation of the PHP Manual and I noticed 
that is hard to find the translation unless you change the option 'view this page 
in' every single time. Here you have 4 different cases where it will be nice to 
see the content directly in Spanish.

Thanks!

Test script:
---------------
case 1.
Add the language Spanish to your Languages list in your browser.
Go to php.net and search for: curl in the search box.
The result is in the English version instead of Spanish.

case 2.
Go to: http://www.php.net/my.php
Change your preferred language from 'not set' to Spanish.
Save all preferences.
Search for: curl in the search box.
The page is in English.

case 3.
Go to http://www.php.net/manual/es/
Search for curl in the search box.
The page is in English.

case 4.
Go to: http://www.php.net/my.php
Change your preferred language from 'not set' to Spanish.
Save all preferences.
Go to: http://www.php.net/curl/
The page is in English.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-23 10:20 UTC] bjori@php.net
-Status: Open +Status: Feedback
 [2010-04-23 10:20 UTC] bjori@php.net
Uhm.
Are you rejecting the cookie?

This has worked fine for the past decade and noone has touched that code for 
years.
 [2010-04-23 10:21 UTC] bjori@php.net
-Status: Feedback +Status: Verified
 [2010-04-23 10:21 UTC] bjori@php.net
Err. Sorry. Just read the thread:
http://news.php.net/php.webmaster/7937

"A brief test shows this works for other languages but not the recently added 
ones (including Persian)."
 [2010-04-27 23:00 UTC] bjori@php.net
-Assigned To: +Assigned To: bjori
 [2010-04-27 23:13 UTC] philip@php.net
The problem is because the sqlite database hasn't been updated for a long time 
(since Dec 9, 2009). So, this bug only affects sqlite enabled mirrors.

The fix: Update the sqlite db on rsync via gen-phpweb-sqlite-db.php
 [2010-04-28 09:39 UTC] bjori@php.net
-Status: Verified +Status: Closed
 [2010-04-28 09:39 UTC] bjori@php.net
Good call philip!

The database wasn't writable by the docbuilder user :)

I'm running the generation script manually now, should get fixed in couple of 
hours.
 [2010-04-28 09:48 UTC] bjori@php.net
Lang: fa
Added entries for 10563 files

Lang: es
Added entries for 10565 files


Should be fine as soon as mirrors have synced
 [2010-04-29 07:08 UTC] philip@php.net
-Status: Closed +Status: Re-Opened
 [2010-04-29 07:08 UTC] philip@php.net
It appears this bug isn't completely solved. :(

1. Set lang to non-en via http://php.net/my
2. Go to the following urls:
- http://au.php.net/curl  (no sqlite --> manual/es (the lang))
- http://au2.php.net/curl (sqlite --> manual/en)

However, now this bug affects all languages so this begs the question: Does the 
script no longer work well with phpdoc?
 [2010-06-05 17:25 UTC] bjori@php.net
Automatic comment from SVN on behalf of bjori
Revision: http://svn.php.net/viewvc/?view=revision&revision=300208
Log: Fixed bug#51628 (hard to find the Spanish translation)
 [2010-06-05 17:25 UTC] bjori@php.net
-Status: Re-Opened +Status: Closed
 [2010-06-05 17:25 UTC] bjori@php.net
This bug has been fixed in SVN. Since the websites are not directly
updated from the SVN server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 [2010-06-05 23:03 UTC] bjori@php.net
Automatic comment from SVN on behalf of bjori
Revision: http://svn.php.net/viewvc/?view=revision&revision=300215
Log: Skip the newly introduce feeds directory too
# See bug#51628
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Dec 03 08:01:29 2023 UTC