php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51521 XMLReader doesn't open files via stream_wrapper
Submitted: 2010-04-09 16:58 UTC Modified: 2010-04-09 20:22 UTC
From: andrey at niakhaichyk dot org Assigned:
Status: Not a bug Package: XML Reader
PHP Version: 5.3.0 OS: Linux i686
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andrey at niakhaichyk dot org
New email:
PHP Version: OS:

 

 [2010-04-09 16:58 UTC] andrey at niakhaichyk dot org
Description:
------------
XMLReader generates the error when tries to open files via stream_wrapper. Works for 5.2.12

Test script:
---------------
http://niakhaichyk.org/xmlreader.bug.txt

Expected result:
----------------
PHP_VERSION: 5.3.0
XML: <?xml version="1.0" encoding="UTF-8"?><root>Thank you</root>
root=
#text=Thank you
root=


Actual result:
--------------
PHP_VERSION: 5.3.0
XML: <?xml version="1.0" encoding="UTF-8"?><root>Thank you</root>


Warning:  XMLReader::open() [xmlreader.open]: Unable to open source data in /var/www/vidunia/public/xmlreader.bug.php on line 12



Warning:  XMLReader::read() [xmlreader.read]: Load Data before trying to read in /var/www/vidunia/public/xmlreader.bug.php on line 13



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-09 19:56 UTC] andrey at niakhaichyk dot org
-PHP Version: 5.3.2 +PHP Version: 5.3.0
 [2010-04-09 19:56 UTC] andrey at niakhaichyk dot org
Tested on old PHP version
 [2010-04-09 19:58 UTC] andrey at niakhaichyk dot org
Cannot reproduce for PHP 5.3.2 Win x32. Seems to was fixed.
 [2010-04-09 19:59 UTC] andrey at niakhaichyk dot org
-Status: Open +Status: Closed
 [2010-04-09 19:59 UTC] andrey at niakhaichyk dot org
Cannot reproduce in 5.3.2
 [2010-04-09 20:22 UTC] pajoye@php.net
-Status: Closed +Status: Bogus
 [2012-09-12 10:21 UTC] ibra_3 at yahoo dot com
I faced same problem while using this code

$objReader = XMLReader::open('reader.xml')

but it was solved here

$objReader = XMLReader;
$objReader->open('reader.xml')

best regards
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 06:01:23 2020 UTC