php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51411 mysql_connect()
Submitted: 2010-03-27 14:02 UTC Modified: 2010-03-27 14:15 UTC
From: modig at rediffmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.2.13 OS: RHEL 5.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: modig at rediffmail dot com
New email:
PHP Version: OS:

 

 [2010-03-27 14:02 UTC] modig at rediffmail dot com
Description:
------------
Dear Supporter

We have two mysql based server both are running same version of o/s, and
mysql. One is acting as master and another one is acting as report server.
The report server is basically replicating data from master server.
From one another server which is acting a web server we are connecting
both server. All though we are not pointing any data manipulation
commands/queries to report server, our report(replication) server is
getting such query.
We are connecting our both servers with below function
"mysql_connect(server, user, pwd, false , 128)

What I am doubting is the fourth parameter is not behaving or returning
some abnormal connection from stack.

Please update me if I am wrong or give me some more specific input on
this.

Mr. Devang Modi
For FSTPL India Gujarat


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-27 14:15 UTC] johannes@php.net
-Status: Open +Status: Bogus
 [2010-03-27 14:15 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

You should always use the named MYSQL_* constants - I have no idea what 128 stands for. Make sure you're assigning the return value of mysql_query to a variable and use that as connection identifier everywhere.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Aug 11 18:03:36 2022 UTC