php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51357 httpd crashes with segfault signal 11
Submitted: 2010-03-23 08:34 UTC Modified: 2010-03-23 11:04 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pesu at obsidian dot cz Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.2.13 OS: CentOS 4.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
29 + 15 = ?
Subscribe to this entry?

 
 [2010-03-23 08:34 UTC] pesu at obsidian dot cz
Description:
------------
Httpd crash often, coredump created, gdb backtrace of coredump ends with:

Reading symbols from /usr/lib64/php/modules/zip.so...Reading symbols from /usr/lib/debug/usr/lib64/php/modules/zip.so.debug...done.
done.
Loaded symbols for /usr/lib64/php/modules/zip.so
Reading symbols from /usr/lib64/gconv/CP1250.so...done.
Loaded symbols for /usr/lib64/gconv/CP1250.so
#0  0x0000002a9633d280 in strlen () from /lib64/tls/libc.so.6
(gdb) bt full
#0  0x0000002a9633d280 in strlen () from /lib64/tls/libc.so.6
No symbol table info available.
#1  0x0000002a9a00a27e in vspprintf (pbuf=0x7fbfffc118, max_len=1024, format=Variable "format" is not available.
) at /usr/src/debug/php-5.2.13/main/spprintf.c:559
        __nl = Variable "__nl" is not available.

Expected result:
----------------
no segfault

Actual result:
--------------
child pid 30052 exit signal Segmentation fault (11)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-23 10:27 UTC] johannes@php.net
-Status: Open +Status: Feedback
 [2010-03-23 10:27 UTC] johannes@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.

And please also add the full stacktrace, the two frames say nothing useful.
 [2010-03-23 10:35 UTC] pesu at obsidian dot cz
-Status: Feedback +Status: Open
 [2010-03-23 10:35 UTC] pesu at obsidian dot cz
I find out, that problem starts when using ZendEncoded file (with ZendOptimizer 3.3.9 x86_64). Because php file is encoded, I have no human readable example script, but I have following bt:

#0  0x0000002a9633d280 in strlen () from /lib64/tls/libc.so.6
#1  0x0000002a9a00a27e in vspprintf (pbuf=0x7fbfffc118, max_len=1024, format=Variable "format" is not available.
) at /usr/src/debug/php-5.2.13/main/spprintf.c:559
#2  0x0000002a9a005b3b in php_error_cb (type=1, 
    error_filename=0x2aa4bdd6a9 "/mnt/raid/www1/vw-scene.cz/wallpapers/license_check.php.lc", error_lineno=4, 
    format=0x29 <Address 0x29 out of bounds>, args=0x11) at /usr/src/debug/php-5.2.13/main/main.c:811
#3  0x0000002a9ffb6daa in soap_error_handler (error_num=41, error_filename=0x209f0 "Ä\020[]A\\Ãff\220ff\220ff\220Hc\025!\005\023", 
    error_lineno=3221211200, format=0x7 <Address 0x7 out of bounds>, args=0x7fbfffc810)
    at /usr/src/debug/php-5.2.13/ext/soap/soap.c:2185
#4  0x0000002a9a049d82 in zend_error (type=1, format=0x2a9a178408 "Non-static method %s::%s() %s be called statically")
    at /usr/src/debug/php-5.2.13/Zend/zend.c:976
#5  0x0000002a9a06a032 in zend_do_fcall_common_helper_SPEC (execute_data=0x7fbfffcc70)
    at /usr/src/debug/php-5.2.13/Zend/zend_vm_execute.h:176
#6  0x0000002a9a0699c1 in execute (op_array=0x552b68cae0) at /usr/src/debug/php-5.2.13/Zend/zend_vm_execute.h:92
#7  0x0000002a9b65590f in zend_oe () from /usr/lib64/php/modules/ZendOptimizer.so
#8  0x0000002a9a0713c0 in ZEND_INCLUDE_OR_EVAL_SPEC_CONST_HANDLER (execute_data=0x7fbfffcff0)
    at /usr/src/debug/php-5.2.13/Zend/zend_vm_execute.h:2098
#9  0x0000002a9a0699c1 in execute (op_array=0x552b68bf30) at /usr/src/debug/php-5.2.13/Zend/zend_vm_execute.h:92
#10 0x0000002a9b65590f in zend_oe () from /usr/lib64/php/modules/ZendOptimizer.so
#11 0x0000002a9a0713c0 in ZEND_INCLUDE_OR_EVAL_SPEC_CONST_HANDLER (execute_data=0x7fbfffd220)
    at /usr/src/debug/php-5.2.13/Zend/zend_vm_execute.h:2098
#12 0x0000002a9a0699c1 in execute (op_array=0x552b68b268) at /usr/src/debug/php-5.2.13/Zend/zend_vm_execute.h:92
#13 0x0000002a9b65590f in zend_oe () from /usr/lib64/php/modules/ZendOptimizer.so
#14 0x0000002a9a04a832 in zend_execute_scripts (type=8, retval=Variable "retval" is not available.
) at /usr/src/debug/php-5.2.13/Zend/zend.c:1134
#15 0x0000002a9a007c2d in php_execute_script (primary_file=0x7fbffff710) at /usr/src/debug/php-5.2.13/main/main.c:2036
#16 0x0000002a9a0da7e6 in php_handler (r=0x552b5f0650) at /usr/src/debug/php-5.2.13/sapi/apache2handler/sapi_apache2.c:639
#17 0x000000552aad4bd3 in ap_run_handler (r=0x552b5f0650) at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/config.c:157
#18 0x000000552aad5091 in ap_invoke_handler (r=0x552b5f0650) at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/config.c:372
#19 0x000000552aae19bf in ap_internal_redirect (new_uri=Variable "new_uri" is not available.
)
    at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/modules/http/http_request.c:501
#20 0x0000002a9937ce33 in handler_redirect (r=0x552cadd778)
    at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/modules/mappers/mod_rewrite.c:4819
#21 0x000000552aad4bd3 in ap_run_handler (r=0x552cadd778) at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/config.c:157
#22 0x000000552aad5091 in ap_invoke_handler (r=0x552cadd778) at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/config.c:372
#23 0x000000552aae1e80 in ap_process_request (r=0x552cadd778)
    at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/modules/http/http_request.c:282
#24 0x000000552aadf3e8 in ap_process_http_connection (c=0x552b5dcee8)
    at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/modules/http/http_core.c:190
#25 0x000000552aadb8d3 in ap_run_process_connection (c=0x552b5dcee8)
    at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/connection.c:43
#26 0x000000552aae61a9 in child_main (child_num_arg=Variable "child_num_arg" is not available.
) at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/mpm/prefork/prefork.c:662
#27 0x000000552aae641a in make_child (s=0x552ac0cac0, slot=14)
    at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/mpm/prefork/prefork.c:758
#28 0x000000552aae6d25 in ap_mpm_run (_pconf=Variable "_pconf" is not available.
) at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/mpm/prefork/prefork.c:893
#29 0x000000552aac1ef9 in main (argc=Variable "argc" is not available.
) at /home/brewbuilder/rpms/BUILD/httpd-2.2.14/server/main.c:740
 [2010-03-23 10:53 UTC] johannes@php.net
-Status: Open +Status: Bogus
 [2010-03-23 10:53 UTC] johannes@php.net
Do not file bugs when you have Zend extensions (zend_extension=)
loaded. Examples are Zend Optimizer, Zend Debugger, Turck MM Cache,
APC, Xdebug and ionCube loader.  These extensions often modify engine
behavior which is not related to PHP itself.

In the stacktrace you can see "Non-static method %s::%s() %s be called statically" so the code is doing something wrong.

Other than that: We can support neither Zend's modifications nor unknown PHP applications.
 [2010-03-23 11:04 UTC] pesu at obsidian dot cz
Ok, thanks for explanation. It's little big confusing me, because everything run fine with php 5.2.11. Will try to contact Zend.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Feb 27 00:01:26 2024 UTC