php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51272 I am getting faulty output with from the str_replace function.
Submitted: 2010-03-11 12:19 UTC Modified: 2010-03-11 14:18 UTC
From: editor at fast dot st Assigned:
Status: Not a bug Package: Strings related
PHP Version: 5.2.13 OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: editor at fast dot st
New email:
PHP Version: OS:

 

 [2010-03-11 12:19 UTC] editor at fast dot st
Description:
------------
I seem to be getting really messed up output when using str_replace in a certain 
situation.

Test script:
---------------
<?php
$out = "[form] [form]";
print_r($out);
print_r('<br>');
$out = str_replace('[form', '[fo<rm', $out);
print_r($out);
die();

Expected result:
----------------
The glitch is obvious...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-11 12:31 UTC] aharvey@php.net
-Status: Open +Status: Feedback
 [2010-03-11 12:31 UTC] aharvey@php.net
You may need to spell out what the "glitch" is, because I get the exact output I'd expect:

[form] [form]<br>[fo<rm] [fo<rm]
 [2010-03-11 14:10 UTC] editor at fast dot st
I'm sorry... Should have assumed it was something unique to my installation. 

My output looks like this:

[form] [form]
[fo

And if I view source I get this:

[form] [form]<br>[fo<rm] [fo>

Also, I think I'm actually on php 5.2.5, on Apache 2.2.6

Cheers,
Dan
 [2010-03-11 14:18 UTC] aharvey@php.net
-Status: Open +Status: Bogus
 [2010-03-11 14:18 UTC] aharvey@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This doesn't sound like a PHP issue, but simply a HTML escaping issue. I'd suggest that you pursue this with one of the support options linked above.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jun 04 19:01:23 2020 UTC