php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51227 You cannot delete a locked file on Windows
Submitted: 2010-03-07 03:05 UTC Modified: 2010-11-22 06:21 UTC
From: whistl0r+php at googlemail dot com Assigned:
Status: Not a bug Package: Streams related
PHP Version: 5.2.13 OS: win32 only
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: whistl0r+php at googlemail dot com
New email:
PHP Version: OS:

 

 [2010-03-07 03:05 UTC] whistl0r+php at googlemail dot com
Description:
------------
A script creates files. To make sure that no "reader" is accessing the file while 
the script is changing its content (think of a cache!), you will use flock() to 
secure the progress.

Tested with PHP Version 5.2.12 (CGI/FastCGI), latest Zend Server release.

Test script:
---------------
<?php
// Set a plain text header
header('Content-Type: text/plain; charset=iso-8859-1');
header('X-Content-Type-Options: nosniff');

$tempFile = tempnam(sys_get_temp_dir(), 'lTest');
if ($tempFile === FALSE)
{
	die('Temp file creation failed!');
}
else
{
	echo 'Our temp file will be: ' . $tempFile . PHP_EOL;
}

$fh = fopen($tempFile, 'w');
if ($fh === FALSE)
{
	die('Cannot get file handler!');
}

$lock = flock($fh, LOCK_EX);
if ($lock === FALSE)
{
	die('Cannot get file lock!');
}

unlink($tempFile);

clearstatcache();
if (file_exists($tempFile) === TRUE)
{
	die('I was unable to delete the file!');
}

$lock = flock($fh, LOCK_UN);
if ($lock === FALSE)
{
	die('Unable to release lock!');
}

fclose($fh);

echo 'Successful! We created a temp file, which we deleted, while the file was locked!' . PHP_EOL;

Expected result:
----------------
I expect that it will work in Windows, like it is working on Linux.
If this isn't possible, it should be documented.

Actual result:
--------------
It will work fine on Linux, but on Windows it will raise a "SHARING VIOLATION" 
(trace it in "Process Monitor" from SysInternals).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-07 03:07 UTC] whistl0r+php at googlemail dot com
Tested on Windows 7, x64.
 [2010-03-10 22:11 UTC] jani@php.net
-Operating System: Windows +Operating System: win32 only
 [2010-11-22 06:21 UTC] cataphract@php.net
-Status: Open +Status: Bogus
 [2010-11-22 06:21 UTC] cataphract@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This is documented in flock(): "flock() uses mandatory locking instead of advisory locking on Windows"
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 20 09:03:33 2022 UTC