php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51209 Bugtracker truncates bugs on 'quotes'
Submitted: 2010-03-05 02:34 UTC Modified: 2010-03-05 13:25 UTC
From: serphen at gmail dot com Assigned: jani (profile)
Status: Closed Package: Website problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
31 + 34 = ?
Subscribe to this entry?

 
 [2010-03-05 02:34 UTC] serphen at gmail dot com
Description:
------------
Previewing a message containing a quote then posting it will truncate the bug report message up to the quote (same when pressing Edit).

Live Example:
I don t know how to reproduce this bug
->
I don


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-05 07:17 UTC] philip@php.net
-Summary: Bugtracker truncates bugs on quote +Summary: Bugtracker truncates bugs on 'quotes'
 [2010-03-05 07:17 UTC] philip@php.net
Interesting. I don't know, will try too.
 [2010-03-05 07:20 UTC] philip at example dot com
I don't know, will try again (this time as a comment, not as developer).
 [2010-03-05 07:21 UTC] philip@php.net
-Status: Open +Status: Feedback
 [2010-03-05 07:21 UTC] philip@php.net
Cannot reproduce, could you provide more information?
 [2010-03-05 07:23 UTC] serphen at gmail dot com
As a comment it works but not with a new bug :)

Try opening a new one, type some text, click Preview and click Edit.
You'll get the bug without the need to actually post it.
 [2010-03-05 07:32 UTC] philip@php.net
-Status: Feedback +Status: Verified
 [2010-03-05 07:32 UTC] philip@php.net
Oh my! Here's the culprit:

<input type='hidden' name='in[ldesc]' value='...'/>

Input there is not properly escaped.
 [2010-03-05 13:25 UTC] jani@php.net
-Status: Verified +Status: Closed
 [2010-03-05 13:25 UTC] jani@php.net
Fixed now. Thanks for the report!
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 08:01:29 2024 UTC