php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #51167 crypt() hangs randomly when called with a salt
Submitted: 2010-02-27 15:24 UTC Modified: 2010-03-03 17:39 UTC
From: david dot joffe at tshwanedje dot com Assigned: pajoye (profile)
Status: Closed Package: *Encryption and hash functions
PHP Version: 5.3.1 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: david dot joffe at tshwanedje dot com
New email:
PHP Version: OS:

 

 [2010-02-27 15:24 UTC] david dot joffe at tshwanedje dot com
Description:
------------
crypt($username, "x8"); // HANGS (Sometimes e.g. 1 out of every 3 times or so)
crypt($username); // NO HANG

Reproduce code:
---------------
$username = 'foo';
crypt($username, "x8");

Actual result:
--------------
Hangs

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-28 12:48 UTC] pajoye@php.net
Please try using PHP 5.3.2RC3. http://windows.php.net/qa/
 [2010-03-03 17:06 UTC] klaus at hax dot at
seems to be fixed in 5.3.2RC3 - will update if anything happens.
 [2010-03-03 17:38 UTC] pajoye@php.net
-Status: Feedback +Status: Closed
 [2010-03-03 17:38 UTC] pajoye@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 [2010-03-03 17:39 UTC] pajoye@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jun 24 06:01:27 2021 UTC